summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/childprocess/childprocess-0.2.1.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.2.1.ebuild b/dev-ruby/childprocess/childprocess-0.2.1.ebuild
new file mode 100644
index 000000000000..ca6f1ecb6fb3
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/childprocess-0.2.1.ebuild,v 1.1 2011/08/12 06:08:59 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="childprocess.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background."
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}