summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/capistrano/capistrano-2.2.0.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-2.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-2.2.0.ebuild b/dev-ruby/capistrano/capistrano-2.2.0.ebuild
new file mode 100644
index 000000000000..6ed1cf3eb1ca
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.2.0.ebuild,v 1.1 2008/04/09 22:07:09 robbat2 Exp $
+
+inherit gems
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rake-0.7.0
+ >=dev-ruby/net-ssh-1.0.10
+ >=dev-ruby/net-sftp-1.1.0
+ >=dev-ruby/highline-1.2.7"
+PDEPEND="dev-ruby/capistrano-launcher"
+
+src_install() {
+ gems_src_install
+
+ # Deleted cap, as it will be provided by capistrano-launcher
+ rm "${D}/usr/bin/cap"
+ rm "${D}/${GEMSDIR}/bin/cap"
+}