summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bcat/bcat-0.6.1.ebuild')
-rw-r--r--dev-ruby/bcat/bcat-0.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bcat/bcat-0.6.1.ebuild b/dev-ruby/bcat/bcat-0.6.1.ebuild
new file mode 100644
index 000000000000..0295d6ddcfa2
--- /dev/null
+++ b/dev-ruby/bcat/bcat-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/bcat-0.6.1.ebuild,v 1.1 2011/06/23 05:48:07 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="man"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pipe to browser utility for use at the shell and within editors like Vim or Emacs."
+HOMEPAGE="http://github.com/rtomayko/bcat"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend "dev-ruby/rack"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/*.1
+}