summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dnspython/ChangeLog9
-rw-r--r--dev-python/dnspython/dnspython-1.7.1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/dnspython/ChangeLog b/dev-python/dnspython/ChangeLog
index 97f602923cc6..3588ebfd2c13 100644
--- a/dev-python/dnspython/ChangeLog
+++ b/dev-python/dnspython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dnspython
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/ChangeLog,v 1.44 2008/05/12 14:27:17 corsair Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/ChangeLog,v 1.45 2009/09/07 19:34:27 patrick Exp $
+
+*dnspython-1.7.1 (07 Sep 2009)
+
+ 07 Sep 2009; Patrick Lauer <patrick@gentoo.org> +dnspython-1.7.1.ebuild:
+ Bump
12 May 2008; Markus Rothe <corsair@gentoo.org> dnspython-1.6.0.ebuild:
Stable on ppc64
diff --git a/dev-python/dnspython/dnspython-1.7.1.ebuild b/dev-python/dnspython/dnspython-1.7.1.ebuild
new file mode 100644
index 000000000000..2e0363d79787
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dnspython/dnspython-1.7.1.ebuild,v 1.1 2009/09/07 19:34:27 patrick Exp $
+
+NEED_PYTHON=2.2
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DOCS="TODO"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r tests
+}
+
+src_test() {
+ export PYTHONPATH="${S}/build/lib:${PYTHONPATH}"
+ cd tests
+ emake || die "Unit tests failed!"
+}
+
+pkg_postinst() {
+ elog "Documentation is sparse at the moment. Use pydoc,"
+ elog "or read the HTML documentation at the dnspython's home page."
+}