summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysqlite/ChangeLog7
-rw-r--r--dev-python/pysqlite/files/digest-pysqlite-2.4.03
-rw-r--r--dev-python/pysqlite/pysqlite-2.4.0.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
index e4cae9d0ea5c..a92020397899 100644
--- a/dev-python/pysqlite/ChangeLog
+++ b/dev-python/pysqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.83 2007/12/22 14:19:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.84 2007/12/26 01:25:57 hawking Exp $
+
+*pysqlite-2.4.0 (26 Dec 2007)
+
+ 26 Dec 2007; Ali Polatel <hawking@gentoo.org> +pysqlite-2.4.0.ebuild:
+ Version bump.
22 Dec 2007; Tobias Scherbaum <dertobi123@gentoo.org>
pysqlite-2.3.5.ebuild:
diff --git a/dev-python/pysqlite/files/digest-pysqlite-2.4.0 b/dev-python/pysqlite/files/digest-pysqlite-2.4.0
new file mode 100644
index 000000000000..07d655d15fdf
--- /dev/null
+++ b/dev-python/pysqlite/files/digest-pysqlite-2.4.0
@@ -0,0 +1,3 @@
+MD5 46b4590c51b9fb62cd0be1439646549e pysqlite-2.4.0.tar.gz 84800
+RMD160 10bacc078d484c2227b272ce59a286a25ca38196 pysqlite-2.4.0.tar.gz 84800
+SHA256 7e66c07d3eb93035f9272d01470e531a7c9f9d9751ad06f3a9c13b4f67c0a06a pysqlite-2.4.0.tar.gz 84800
diff --git a/dev-python/pysqlite/pysqlite-2.4.0.ebuild b/dev-python/pysqlite/pysqlite-2.4.0.ebuild
new file mode 100644
index 000000000000..9ce3baed09cd
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-2.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-2.4.0.ebuild,v 1.1 2007/12/26 01:25:57 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="http://initd.org/pub/software/pysqlite/releases/${PV:0:3}/${PV}/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://initd.org/tracker/pysqlite/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="pysqlite"
+SLOT="2"
+IUSE="examples"
+
+DEPEND=">=dev-db/sqlite-3.1"
+
+PYTHON_MODNAME="pysqlite2"
+
+src_unpack() {
+ distutils_src_unpack
+ # don't install pysqlite2.test
+ sed -i -e 's/, "pysqlite2.test"//' \
+ setup.py || die "sed in setup.py failed"
+ # workaround to make checks work without installing them
+ sed -i -e "s/pysqlite2.test/test/" \
+ pysqlite2/test/__init__.py || die "sed failed"
+ # correct encoding
+ sed -i -e "s/\(coding: \)ISO-8859-1/\1utf-8/" \
+ pysqlite2/__init__.py pysqlite2/dbapi2.py || die "sed failed"
+}
+
+src_install() {
+ DOCS="doc/usage-guide.txt"
+ distutils_src_install
+
+ rm -rf "${D}"/usr/pysqlite2-doc
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/code
+ fi
+}
+
+src_test() {
+ cd pysqlite2
+ # tests use this as a nonexistant file
+ addpredict /foo/bar
+ PYTHONPATH="$(ls -d ../build/lib.*)" "${python}" -c \
+ "from test import test;import sys;sys.exit(test())" \
+ || die "test failed"
+}