summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urwid/urwid-0.9.8.1.ebuild')
-rw-r--r--dev-python/urwid/urwid-0.9.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/urwid/urwid-0.9.8.1.ebuild b/dev-python/urwid/urwid-0.9.8.1.ebuild
new file mode 100644
index 000000000000..dd33c68c4096
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.8.1.ebuild,v 1.1 2007/06/24 19:11:17 lucass Exp $
+
+NEED_PYTHON=2.2
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_test() {
+ "${python}" test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bigtext.py browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}