summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sympy/sympy-0.7.2-r1.ebuild')
-rw-r--r--dev-python/sympy/sympy-0.7.2-r1.ebuild33
1 files changed, 19 insertions, 14 deletions
diff --git a/dev-python/sympy/sympy-0.7.2-r1.ebuild b/dev-python/sympy/sympy-0.7.2-r1.ebuild
index dd2d7cbf01a4..d3e895eab36a 100644
--- a/dev-python/sympy/sympy-0.7.2-r1.ebuild
+++ b/dev-python/sympy/sympy-0.7.2-r1.ebuild
@@ -1,24 +1,27 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/sympy-0.7.2-r1.ebuild,v 1.4 2013/10/13 10:17:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/sympy-0.7.2-r1.ebuild,v 1.5 2013/10/15 18:17:35 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
inherit distutils-r1 eutils
DESCRIPTION="Computer algebra system (CAS) in Python"
HOMEPAGE="http://sympy.org/"
-SRC_URI="python_targets_python2_6? ( http://sympy.googlecode.com/files/${P}.tar.gz )
+SRC_URI="
+ python_targets_python2_6? ( http://sympy.googlecode.com/files/${P}.tar.gz )
python_targets_python2_7? ( http://sympy.googlecode.com/files/${P}.tar.gz )
- python_targets_python3_2? ( http://sympy.googlecode.com/files/${P}-py3.2.tar.gz )"
+ python_targets_python3_2? ( http://sympy.googlecode.com/files/${P}-py3.2.tar.gz )
+ python_targets_python3_3? ( http://sympy.googlecode.com/files/${P}-py3.2.tar.gz )"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet system-mpmath test texmacs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
mathml? (
- dev-libs/libxml2:2[python]
- dev-libs/libxslt[python]
+ dev-libs/libxml2:2[${PYTHON_USEDEP}]
+ dev-libs/libxslt[python_targets_python2_6?,python_targets_python2_7?]
gtk? ( x11-libs/gtkmathview[gtk] ) )
latex? (
virtual/latex-base
@@ -27,20 +30,21 @@ RDEPEND="
pdf? ( app-text/ghostscript-gpl ) )
texmacs? ( app-office/texmacs )
ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[python_targets_python2_6?,python_targets_python2_7?] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
imaging? ( virtual/python-imaging[${PYTHON_USEDEP}] )
pyglet? ( dev-python/pyglet[python_targets_python2_6?,python_targets_python2_7?] )
>=dev-python/pexpect-2.0[python_targets_python2_6?,python_targets_python2_7?]
system-mpmath? ( ~dev-python/mpmath-0.17[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
S="${WORKDIR}"
system_mpmath() {
local MPMATH_FILES
- MPMATH_FILES="sympy/combinatorics/permutations.py \
+ MPMATH_FILES="
+ sympy/combinatorics/permutations.py \
sympy/core/containers.py \
sympy/core/evalf.py \
sympy/core/expr.py \
@@ -105,8 +109,9 @@ system_mpmath() {
sympy/utilities/tests/test_lambdify.py \
examples/advanced/pidigits.py \
examples/advanced/autowrap_ufuncify.py"
- rm -rf sympy/mpmath/*
- sed -e "s:sympy\.mpmath:mpmath:g" \
+ rm -rf sympy/mpmath/* || die
+ sed \
+ -e "s:sympy\.mpmath:mpmath:g" \
-e "s:from sympy import mpmath:import mpmath:g" \
-i ${MPMATH_FILES} || die "failed to patch mpmath imports"
epatch "${FILESDIR}"/${P}-mpmath.patch
@@ -114,13 +119,13 @@ system_mpmath() {
src_unpack() {
if use python_targets_python2_6 || use python_targets_python2_7; then
- mkdir "${WORKDIR}"/python2
- cd "${WORKDIR}"/python2
+ mkdir "${WORKDIR}"/python2 || die
+ cd "${WORKDIR}"/python2 || die
unpack ${P}.tar.gz
fi
if use python_targets_python3_2; then
- mkdir "${WORKDIR}"/python3
- cd "${WORKDIR}"/python3
+ mkdir "${WORKDIR}"/python3 || die
+ cd "${WORKDIR}"/python3 || die
unpack ${P}-py3.2.tar.gz
fi
}