summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-exec/python-exec-0.1.ebuild')
-rw-r--r--dev-python/python-exec/python-exec-0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-exec/python-exec-0.1.ebuild b/dev-python/python-exec/python-exec-0.1.ebuild
new file mode 100644
index 000000000000..17f64cb7c97c
--- /dev/null
+++ b/dev-python/python-exec/python-exec-0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-0.1.ebuild,v 1.1 2012/10/14 10:57:27 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+append_impl() {
+ pyimpls+="${EPYTHON} "
+}
+
+src_configure() {
+ local pyimpls
+ python_foreach_impl append_impl
+
+ local myeconfargs=(
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}