summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild')
-rw-r--r--dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild b/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild
index ab69b308b90a..36533991f9c5 100644
--- a/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild
+++ b/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild,v 1.2 2007/05/05 17:18:09 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/pyprotocols-1.0_pre2306.ebuild,v 1.3 2007/05/05 19:46:49 lucass Exp $
NEED_PYTHON=2.4
inherit distutils
-KEYWORDS="~x86"
-
MY_PN=PyProtocols
MY_P=${MY_PN}-${PV/_pre/a0dev_r}
DESCRIPTION="Extends the PEP 246 adapt() function with a new 'declaration API' that lets you easily define your own protocols and adapters, and declare what adapters should be used to adapt what types, objects, or protocols."
HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html"
SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
LICENSE="|| ( PSF-2.4 ZPL )"
SLOT="0"
IUSE=""
@@ -22,7 +21,10 @@ RDEPEND=">=dev-python/decoratortools-1.4"
DEPEND="${RDEPEND}
>=dev-python/setuptools-0.6_rc5"
-S=${WORKDIR}/${MY_PN}
+S="${WORKDIR}/${MY_PN}"
PYTHON_MODNAME="protocols"
+src_test() {
+ PYTHONPATH="./src/" "${python}" setup.py test || die "tests failed"
+}