summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups/pycups-1.9.57.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.57.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pycups/pycups-1.9.57.ebuild b/dev-python/pycups/pycups-1.9.57.ebuild
index f9cc15df7c69..1e9f284b7813 100644
--- a/dev-python/pycups/pycups-1.9.57.ebuild
+++ b/dev-python/pycups/pycups-1.9.57.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.57.ebuild,v 1.6 2011/08/10 21:03:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.57.ebuild,v 1.7 2011/09/12 22:26:15 reavertm Exp $
-EAPI="2"
+EAPI="3"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit distutils flag-o-matic
DESCRIPTION="Python bindings for the CUPS API"
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
doc? ( dev-python/epydoc )
"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_compile() {
append-cflags -DVERSION=\\\"${PV}\\\"
distutils_src_compile