summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycrypto/pycrypto-2.0.1-r7.ebuild')
-rw-r--r--dev-python/pycrypto/pycrypto-2.0.1-r7.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/pycrypto/pycrypto-2.0.1-r7.ebuild b/dev-python/pycrypto/pycrypto-2.0.1-r7.ebuild
deleted file mode 100644
index 199c6e5934da..000000000000
--- a/dev-python/pycrypto/pycrypto-2.0.1-r7.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/pycrypto-2.0.1-r7.ebuild,v 1.3 2010/02/07 20:32:46 pva Exp $
-
-EAPI=1
-NEED_PYTHON=2.5
-inherit eutils distutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="Python Cryptography Toolkit"
-HOMEPAGE="http://www.amk.ca/python/code/crypto.html"
-SRC_URI="http://www.amk.ca/files/python/crypto/${P}.tar.gz"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bindist gmp test"
-
-RDEPEND="virtual/python
- gmp? ( dev-libs/gmp )"
-DEPEND="${RDEPEND}
- test? ( =dev-python/sancho-0.11-r1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use bindist && epatch "${FILESDIR}"/${P}-bindist.patch
- epatch "${FILESDIR}"/${P}-sha256.patch
- epatch "${FILESDIR}"/${P}-sha256-2.patch
- epatch "${FILESDIR}"/${P}-gmp.patch
- epatch "${FILESDIR}"/${P}-uint32.patch
- epatch "${FILESDIR}"/${P}-sancho-package-rename.patch
- epatch "${FILESDIR}"/${P}-2.6_hashlib.patch
-}
-
-src_compile() {
- use gmp \
- && export USE_GMP=1 \
- || export USE_GMP=0
- # sha256 hashes occasionally trigger ssp when built with
- # -finline-functions (implied by -O3).
- gcc-specs-ssp && append-flags -fno-inline-functions
- distutils_src_compile
- python_need_rebuild
-}
-
-src_test() {
- export PYTHONPATH=$(ls -d "${S}"/build/lib.*/)
- python ./test.py || die "test failed"
- if use test ; then
- local x
- cd test
- for x in test_*.py ; do
- python ${x} || die "${x} failed"
- done
- fi
-}
-
-DOCS="ACKS ChangeLog PKG-INFO README TODO Doc/pycrypt.tex"