summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyconstruct/pyconstruct-2.04.ebuild')
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.04.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pyconstruct/pyconstruct-2.04.ebuild b/dev-python/pyconstruct/pyconstruct-2.04.ebuild
new file mode 100644
index 000000000000..d3068c0aa6f5
--- /dev/null
+++ b/dev-python/pyconstruct/pyconstruct-2.04.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.04.ebuild,v 1.1 2011/09/16 08:24:21 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+MY_PN="construct"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize construct
+}
+
+pkg_postrm() {
+ python_mod_cleanup construct
+} \ No newline at end of file