summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py/py-1.3.4.ebuild')
-rw-r--r--dev-python/py/py-1.3.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/py/py-1.3.4.ebuild b/dev-python/py/py-1.3.4.ebuild
index 0df6d9461618..334799eef571 100644
--- a/dev-python/py/py-1.3.4.ebuild
+++ b/dev-python/py/py-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.3.4.ebuild,v 1.7 2010/10/23 18:17:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.3.4.ebuild,v 1.8 2010/12/27 16:43:56 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -22,6 +22,9 @@ RDEPEND="${DEPEND}"
src_prepare() {
distutils_src_prepare
+ # Disable versioning of py.test and py.which scripts to avoid collisions with versioning performed by distutils_src_install().
+ sed -e "77a\ points = {}" -i setup.py
+
# Disable failing tests.
rm -f testing/path/test_svnwc.py
}