summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-1.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 18edc440b0dc..390d8ae3a03f 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.8 2012/06/06 05:18:30 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.9 2012/09/02 02:49:50 radhermit Exp $
+
+*pip-1.2 (02 Sep 2012)
+
+ 02 Sep 2012; Tim Harder <radhermit@gentoo.org> +pip-1.2.ebuild:
+ Version bump.
06 Jun 2012; Benda Xu <heroxbd@gentoo.org> pip-1.1.ebuild:
keyword ~amd64-linux and ~x86-linux
diff --git a/dev-python/pip/pip-1.2.ebuild b/dev-python/pip/pip-1.2.ebuild
new file mode 100644
index 000000000000..7e14ad6130f2
--- /dev/null
+++ b/dev-python/pip/pip-1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.2.ebuild,v 1.1 2012/09/02 02:49:50 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit bash-completion-r1 distutils eutils
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+# Tests require a couple libraries not yet in the tree, aren't bundled with
+# the default tarball from pypi, and have a couple failures anyway
+RESTRICT="test"
+
+DOCS="AUTHORS.txt docs/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-unversioned.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ COMPLETION="${T}/completion.tmp"
+
+ "$(PYTHON -f)" pip/runner.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ if use zsh-completion ; then
+ "$(PYTHON -f)" pip/runner.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+ fi
+}