summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/networkx/networkx-1.9.ebuild')
-rw-r--r--dev-python/networkx/networkx-1.9.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/networkx/networkx-1.9.ebuild b/dev-python/networkx/networkx-1.9.ebuild
deleted file mode 100644
index 5068db226549..000000000000
--- a/dev-python/networkx/networkx-1.9.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/networkx/networkx-1.9.ebuild,v 1.2 2014/08/15 00:17:57 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="http://networkx.github.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PY2_USEDEP}]
- $(python_gen_cond_dep 'dev-python/numpydoc[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]' python2_7 'python{3_3,3_4}')
- )
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )"
-RDEPEND=">=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
- examples? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PY2_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed -e "s/'sphinx.ext.intersphinx', //" -i doc/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sed \
- -e "s:^\t\./:\t${PYTHON} :g" \
- -i doc/Makefile || die
- emake -C doc html
- fi
-}
-
-python_test() {
- nosetests -vv || die
-}
-
-python_install_all() {
- # Oh my.
- rm -r "${ED}"usr/share/doc/${P} || die
-
- use doc && local HTML_DOCS=( doc/build/html/. )
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}