summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imdbpy/imdbpy-4.4.ebuild')
-rw-r--r--dev-python/imdbpy/imdbpy-4.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/imdbpy/imdbpy-4.4.ebuild b/dev-python/imdbpy/imdbpy-4.4.ebuild
new file mode 100644
index 000000000000..dba3fc1fc3af
--- /dev/null
+++ b/dev-python/imdbpy/imdbpy-4.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imdbpy/imdbpy-4.4.ebuild,v 1.1 2010/01/09 20:55:19 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="IMDbPY"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python package to access the IMDb movie database"
+HOMEPAGE="http://imdbpy.sourceforge.net/ http://pypi.python.org/pypi/IMDbPY"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PYTHON_MODNAME="imdb"
+
+src_install() {
+ distutils_src_install
+ dodoc docs/*
+}