summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/freezegun/freezegun-0.3.5.ebuild')
-rw-r--r--dev-python/freezegun/freezegun-0.3.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/freezegun/freezegun-0.3.5.ebuild b/dev-python/freezegun/freezegun-0.3.5.ebuild
new file mode 100644
index 000000000000..ec32d45c7428
--- /dev/null
+++ b/dev-python/freezegun/freezegun-0.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/freezegun/freezegun-0.3.5.ebuild,v 1.1 2015/08/08 12:15:24 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Let your Python tests travel through time"
+HOMEPAGE="https://github.com/spulec/freezegun"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}