summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/epydoc/epydoc-1.1.ebuild')
-rw-r--r--dev-python/epydoc/epydoc-1.1.ebuild33
1 files changed, 15 insertions, 18 deletions
diff --git a/dev-python/epydoc/epydoc-1.1.ebuild b/dev-python/epydoc/epydoc-1.1.ebuild
index 2ace9662b3fd..9f5e2e36c8aa 100644
--- a/dev-python/epydoc/epydoc-1.1.ebuild
+++ b/dev-python/epydoc/epydoc-1.1.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epydoc/epydoc-1.1.ebuild,v 1.1 2002/12/05 14:07:37 lordvan Exp $
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epydoc/epydoc-1.1.ebuild,v 1.1.1.1 2005/11/30 10:10:32 chriswhite Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION=" Epydoc is a tool for generating API documentation for Python modules, based on their docstrings."
-SRC_URI="mirror://sourceforge/epydoc/${P}.tar.gz"
+inherit distutils
+
+DESCRIPTION="tool for generating API documentation for Python modules, based on their docstrings"
HOMEPAGE="http://epydoc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/epydoc/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
-RDEPEND="virtual/python"
-DEPEND="$DEPEND"
-KEYWORDS="~x86"
+KEYWORDS="x86 alpha ia64"
IUSE=""
-inherit distutils
+RDEPEND="virtual/python"
src_install() {
- distutils_src_install
+ distutils_src_install
- # copy docs (using cp -r cuz of some sub-dirs)
- cp -r ${S}/doc/* ${D}/usr/share/doc/${P}/
-
- # man-pages
- doman ${S}/man/*
-
+ # copy docs (using cp -r cuz of some sub-dirs)
+ cp -r ${S}/doc/* ${D}/usr/share/doc/${PF}/
+ prepalldocs
+ doman ${S}/man/*
}
-