summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django/django-0.91.ebuild')
-rw-r--r--dev-python/django/django-0.91.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/django/django-0.91.ebuild b/dev-python/django/django-0.91.ebuild
index 9958c36fd1e4..bb108f64cfce 100644
--- a/dev-python/django/django-0.91.ebuild
+++ b/dev-python/django/django-0.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.91.ebuild,v 1.2 2006/03/29 15:30:35 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-0.91.ebuild,v 1.3 2006/03/30 16:58:31 lucass Exp $
inherit distutils
@@ -16,11 +16,13 @@ IUSE="sqlite postgres mysql"
DEPEND=">=dev-lang/python-2.3
dev-python/setuptools"
-RDEPEND="sqlite? ( >=dev-python/pysqlite-2.0.3 )
+RDEPEND=">=dev-lang/python-2.3
+ sqlite? ( >=dev-python/pysqlite-2.0.3 )
postgres? ( dev-python/psycopg )
mysql? ( dev-python/mysql-python )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+DOCS="docs/* AUTHORS INSTALL LICENSE"
src_install()
{
@@ -30,8 +32,5 @@ src_install()
export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
dodir ${site_pkgs}
- ${python} setup.py install --root=${D} --no-compile \
- --single-version-externally-managed "$@" || die
-
- dodoc docs/* AUTHORS INSTALL LICENSE README PKG-INFO
+ distutils_src_install --single-version-externally-managed
}