summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cheetah/cheetah-2.4.2.ebuild')
-rw-r--r--dev-python/cheetah/cheetah-2.4.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cheetah/cheetah-2.4.2.ebuild b/dev-python/cheetah/cheetah-2.4.2.ebuild
new file mode 100644
index 000000000000..9e4e481d9405
--- /dev/null
+++ b/dev-python/cheetah/cheetah-2.4.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-2.4.2.ebuild,v 1.1 2010/02/08 13:44:35 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Cheetah"
+MY_P="${MY_PN}-${PV/_}"
+
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/ http://rtyler.github.com/cheetah/ http://pypi.python.org/pypi/Cheetah"
+SRC_URI="http://pypi.python.org/packages/source/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+
+RDEPEND="dev-python/markdown"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Cheetah"
+DOCS="CHANGES README.markdown TODO"
+
+src_prepare() {
+ # Disable broken tests.
+ sed \
+ -e "/Unicode/d" \
+ -e "s/if not sys.platform.startswith('java'):/if False:/" \
+ -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
+ -i cheetah/Tests/Test.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" cheetah/Tests/Test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ [[ -z "${ED}" ]] && local ED="${D}"
+ distutils_src_install
+ rm -fr "${ED}"usr/lib*/python*/site-packages/Cheetah/Tests
+}