summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt/PyQt_qt2.3.1-3.0.ebuild')
-rw-r--r--dev-python/PyQt/PyQt_qt2.3.1-3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/PyQt/PyQt_qt2.3.1-3.0.ebuild b/dev-python/PyQt/PyQt_qt2.3.1-3.0.ebuild
new file mode 100644
index 000000000000..82354ae9e6d0
--- /dev/null
+++ b/dev-python/PyQt/PyQt_qt2.3.1-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt_qt2.3.1-3.0.ebuild,v 1.1 2001/11/29 20:37:49 verwilst Exp $
+
+S="${WORKDIR}/PyQt-3.0"
+DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
+SRC_URI="http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-2.3.1.tar.gz"
+HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+
+DEPEND="virtual/glibc
+ >=x11-libs/qt-x11-2.3
+ =dev-python/sip-3.0
+ >=dev-lang/python-2.0"
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc
+ assert
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-doc || die
+}