summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/suhosin/suhosin-0.9.27.ebuild')
-rw-r--r--dev-php5/suhosin/suhosin-0.9.27.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php5/suhosin/suhosin-0.9.27.ebuild b/dev-php5/suhosin/suhosin-0.9.27.ebuild
new file mode 100644
index 000000000000..de9459db6ac9
--- /dev/null
+++ b/dev-php5/suhosin/suhosin-0.9.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/suhosin-0.9.27.ebuild,v 1.1 2008/08/23 11:09:09 hoffie Exp $
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations."
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://download.suhosin.org/${P}.tgz"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use unicode
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php CREDITS
+
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+}