summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/pecl-memcache')
-rw-r--r--dev-php5/pecl-memcache/ChangeLog8
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-2.2.4.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index 729b60c6c604..0712351f51cd 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.24 2008/10/18 20:52:39 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.25 2008/11/11 22:26:50 robbat2 Exp $
+
+*pecl-memcache-2.2.4 (11 Nov 2008)
+
+ 11 Nov 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +pecl-memcache-2.2.4.ebuild:
+ Version bump in the upstream stable series (3.x is still beta upstream).
*pecl-memcache-3.0.2 (18 Oct 2008)
diff --git a/dev-php5/pecl-memcache/pecl-memcache-2.2.4.ebuild b/dev-php5/pecl-memcache/pecl-memcache-2.2.4.ebuild
new file mode 100644
index 000000000000..f427af7f1b0e
--- /dev/null
+++ b/dev-php5/pecl-memcache/pecl-memcache-2.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-2.2.4.ebuild,v 1.1 2008/11/11 22:26:50 robbat2 Exp $
+
+EAPI="1"
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r1 php-ext-base-r1 depend.php
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ use session && require_php_with_use session
+}
+
+src_compile() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-base-r1_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-base-r1_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-base-r1_addtoinifiles "memcache.default_port" "11211"
+ php-ext-base-r1_addtoinifiles "memcache.hash_strategy" "standard"
+ php-ext-base-r1_addtoinifiles "memcache.hash_function" "crc32"
+}