summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/suhosin/ChangeLog8
-rw-r--r--dev-php4/suhosin/files/digest-suhosin-0.9.223
-rw-r--r--dev-php4/suhosin/suhosin-0.9.22.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-php4/suhosin/ChangeLog b/dev-php4/suhosin/ChangeLog
index 92ddfe6bd244..fb2abbf977ff 100644
--- a/dev-php4/suhosin/ChangeLog
+++ b/dev-php4/suhosin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/suhosin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/suhosin/ChangeLog,v 1.18 2007/10/15 14:20:30 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/suhosin/ChangeLog,v 1.19 2007/12/04 11:11:00 hoffie Exp $
+
+*suhosin-0.9.22 (04 Dec 2007)
+
+ 04 Dec 2007; Christian Hoffmann <hoffie@gentoo.org>
+ +suhosin-0.9.22.ebuild:
+ bump to 0.9.22, bug 200921; completely untested, use at your own risk
15 Oct 2007; Markus Rothe <corsair@gentoo.org> suhosin-0.9.18.ebuild:
Stable on ppc64
diff --git a/dev-php4/suhosin/files/digest-suhosin-0.9.22 b/dev-php4/suhosin/files/digest-suhosin-0.9.22
new file mode 100644
index 000000000000..e19f65567292
--- /dev/null
+++ b/dev-php4/suhosin/files/digest-suhosin-0.9.22
@@ -0,0 +1,3 @@
+MD5 d448329e7003a33b7d631ea41f01ed6d suhosin-0.9.22.tgz 112326
+RMD160 b94ac4b0962c4df80443f18e557ba425cfd0a0ee suhosin-0.9.22.tgz 112326
+SHA256 e2a066cb9b66b013dbb4612a09d1b6768cf00832bdc05ae8038a8b25fbc749be suhosin-0.9.22.tgz 112326
diff --git a/dev-php4/suhosin/suhosin-0.9.22.ebuild b/dev-php4/suhosin/suhosin-0.9.22.ebuild
new file mode 100644
index 000000000000..5e58a8954ea4
--- /dev/null
+++ b/dev-php4/suhosin/suhosin-0.9.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/suhosin/suhosin-0.9.22.ebuild,v 1.1 2007/12/04 11:11:00 hoffie Exp $
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://www.hardened-php.net/suhosin/_media/${P}.tgz"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use unicode
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php CREDITS
+
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+}