summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/module-build')
-rw-r--r--dev-perl/module-build/ChangeLog7
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.28.053
-rw-r--r--dev-perl/module-build/module-build-0.28.05.ebuild29
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
index 63e9e7f5137f..2230a0855bee 100644
--- a/dev-perl/module-build/ChangeLog
+++ b/dev-perl/module-build/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/module-build
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.48 2006/08/18 02:14:40 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.49 2006/08/21 12:34:44 yuval Exp $
+
+*module-build-0.28.05 (21 Aug 2006)
+
+ 21 Aug 2006; Yuval Yaari <yuval@gentoo.org> +module-build-0.28.05.ebuild:
+ Version bump
18 Aug 2006; Michael Cummings <mcummings@gentoo.org>
module-build-0.28-r1.ebuild:
diff --git a/dev-perl/module-build/files/digest-module-build-0.28.05 b/dev-perl/module-build/files/digest-module-build-0.28.05
new file mode 100644
index 000000000000..0ba5d33573a1
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.28.05
@@ -0,0 +1,3 @@
+MD5 598bb59b86c2c4842eeffb03392fab5b Module-Build-0.2805.tar.gz 185749
+RMD160 82cb42062df7f97cf87bee74e07f834df2909c1f Module-Build-0.2805.tar.gz 185749
+SHA256 8fd609d1e6b460b5c95ad5612cb823aa863d51360ed55caea987909a9bab50f5 Module-Build-0.2805.tar.gz 185749
diff --git a/dev-perl/module-build/module-build-0.28.05.ebuild b/dev-perl/module-build/module-build-0.28.05.ebuild
new file mode 100644
index 000000000000..a71ab7817aa3
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28.05.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.05.ebuild,v 1.1 2006/08/21 12:34:44 yuval Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/${MY_P}/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"