summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild')
-rw-r--r--dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild b/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild
index b0d325807f59..4036a7590ff1 100644
--- a/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild
+++ b/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild,v 1.1 2009/06/23 07:35:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Class-C3-Componentised/Class-C3-Componentised-1.0005.ebuild,v 1.2 2009/06/23 13:38:23 tove Exp $
-MODULE_AUTHOR="ASH"
EAPI=2
+MODULE_AUTHOR=ASH
inherit perl-module
-DESCRIPTION="Load mix-ins or components to your C3-based class"
-
-IUSE=""
+DESCRIPTION="Load mix-ins or components to your C3-based class."
SLOT="0"
-LICENSE="|| ( Artistic GPL-2 )"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
-DEPEND="dev-perl/Test-Exception
+RDEPEND="dev-perl/MRO-Compat
dev-perl/Class-Inspector
- dev-perl/MRO-Compat
- >=dev-perl/Class-C3-0.21"
-RDEPEND="${DEPEND}"
+ >=dev-perl/Class-C3-0.20"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception )"
+
+SRC_TEST=do