summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Apache-Test/Apache-Test-1.360.ebuild')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.360.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.360.ebuild b/dev-perl/Apache-Test/Apache-Test-1.360.ebuild
new file mode 100644
index 000000000000..fac0bd5eb7ed
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.360.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.360.ebuild,v 1.1 2011/02/04 07:32:00 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.36
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}