summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sqlite3/files')
-rw-r--r--dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-0.23.0-noocamlopt.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-0.23.0-noocamlopt.patch b/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-0.23.0-noocamlopt.patch
new file mode 100644
index 000000000000..cac7e4700446
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-0.23.0-noocamlopt.patch
@@ -0,0 +1,16 @@
+Index: ocaml-sqlite3-0.23.0/Makefile.in
+===================================================================
+--- ocaml-sqlite3-0.23.0.orig/Makefile.in
++++ ocaml-sqlite3-0.23.0/Makefile.in
+@@ -33,9 +33,9 @@ distclean: clean
+
+ # install rebuilds sqlite3top to point to the findlib-managed dll and not the
+ # one in .
+-install: sqlite3.cma sqlite3.cmxa sqlite3top
++install: sqlite3.cma sqlite3top
+ [ -f *.so ] && SO_FILES=*.so; \
+- ocamlfind install sqlite3 META sqlite3.cmi sqlite3.mli sqlite3.cma *.cmxa *.a *.cmx $$SO_FILES
++ ocamlfind install sqlite3 META sqlite3.cmi sqlite3.mli sqlite3.cma $(wildcard *.cmxa *.a *.cmx) $$SO_FILES
+ ocamlfind ocamlmktop -o sqlite3top -package "sqlite3" sqlite3.cma
+ $(INSTALL) -D sqlite3top $(DESTDIR)$(bindir)/sqlite3top
+