summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-webactions/cl-webactions-1.2.35.20040924.ebuild')
-rw-r--r--dev-lisp/cl-webactions/cl-webactions-1.2.35.20040924.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lisp/cl-webactions/cl-webactions-1.2.35.20040924.ebuild b/dev-lisp/cl-webactions/cl-webactions-1.2.35.20040924.ebuild
new file mode 100644
index 000000000000..57c79271e3f7
--- /dev/null
+++ b/dev-lisp/cl-webactions/cl-webactions-1.2.35.20040924.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-webactions/cl-webactions-1.2.35.20040924.ebuild,v 1.1 2004/10/15 03:52:11 mkennedy Exp $
+
+inherit common-lisp eutils
+
+MY_PV=${PV:0:6}
+CVS_PV=${PV:7:4}.${PV:11:2}.${PV:13}
+
+DESCRIPTION="Webactions is Franz's library for dispatching HTTP requests as well as processing HTML templates."
+HOMEPAGE="http://packages.debian.org/unstable/web/cl-webactions.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs.${CVS_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ =dev-lisp/cl-aserve-${PV}"
+
+CLPACKAGE=webactions
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs.${CVS_PV}
+
+src_install() {
+ common-lisp-install aserve/webactions/*.cl aserve/webactions/*.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/webactions/clpcode; doins aserve/webactions/clpcode/*.cl
+ dohtml aserve/webactions/doc/*
+ dodoc aserve/webactions/ChangeLog
+ docinto examples
+ dodoc contrib/*.lisp
+ do-debian-credits
+}