summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-cclan/cl-cclan-1.86.ebuild')
-rw-r--r--dev-lisp/cl-cclan/cl-cclan-1.86.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lisp/cl-cclan/cl-cclan-1.86.ebuild b/dev-lisp/cl-cclan/cl-cclan-1.86.ebuild
new file mode 100644
index 000000000000..0903374bf048
--- /dev/null
+++ b/dev-lisp/cl-cclan/cl-cclan-1.86.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-cclan/cl-cclan-1.86.ebuild,v 1.1 2005/04/15 19:04:31 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DEB_PV=2
+
+DESCRIPTION="Comprehensive Common Lisp Archive Network"
+HOMEPAGE="http://cclan.sourceforge.net http://www.cliki.net/cclan http://packages.debian.org/unstable/devel/cl-cclan.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}-${DEB_PV}.diff.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-asdf/cl-asdf_${PV}.orig.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="dev-lisp/cl-asdf
+ virtual/commonlisp
+ dev-lisp/common-lisp-controller"
+
+CLPACKAGE=cclan
+
+S=${WORKDIR}/cl-asdf-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch cl-asdf_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ common-lisp-install cclan*.lisp cclan.asd
+ common-lisp-system-symlink
+ do-debian-credits
+}