summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/stfl/ChangeLog8
-rw-r--r--dev-libs/stfl/stfl-0.17.ebuild34
-rw-r--r--dev-libs/stfl/stfl-0.18.ebuild23
-rw-r--r--dev-libs/stfl/stfl-0.19.ebuild20
4 files changed, 35 insertions, 50 deletions
diff --git a/dev-libs/stfl/ChangeLog b/dev-libs/stfl/ChangeLog
index 1d7db36cc687..6bae3551f6c2 100644
--- a/dev-libs/stfl/ChangeLog
+++ b/dev-libs/stfl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/stfl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.20 2008/09/23 07:40:48 corsair Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.21 2009/03/07 19:23:13 gentoofan23 Exp $
+
+ 07 Mar 2009; Thomas Anderson <gentoofan23@gentoo.org> stfl-0.17.ebuild,
+ stfl-0.18.ebuild, stfl-0.19.ebuild:
+ Transition to eapi 2 use deps
23 Sep 2008; Markus Rothe <corsair@gentoo.org> stfl-0.19.ebuild:
Added ~ppc
diff --git a/dev-libs/stfl/stfl-0.17.ebuild b/dev-libs/stfl/stfl-0.17.ebuild
index 3ccce1794250..97b85355453c 100644
--- a/dev-libs/stfl/stfl-0.17.ebuild
+++ b/dev-libs/stfl/stfl-0.17.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.17.ebuild,v 1.4 2008/06/22 17:30:49 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.17.ebuild,v 1.5 2009/03/07 19:23:13 gentoofan23 Exp $
-inherit perl-module toolchain-funcs eutils
+inherit eutils perl-module python toolchain-funcs
DESCRIPTION="A library which implements a curses-based widget set for text terminals"
HOMEPAGE="http://www.clifford.at/stfl/"
@@ -14,13 +14,15 @@ KEYWORDS="x86"
IUSE="examples perl ruby"
-DEPEND="sys-libs/ncurses
- perl? ( dev-lang/swig dev-lang/perl )
- ruby? ( dev-lang/swig dev-lang/ruby )"
+COMMON_DEPEND="sys-libs/ncurses[unicode]
+ perl? ( dev-lang/perl )
+ ruby? ( dev-lang/ruby )"
-RDEPEND="sys-libs/ncurses
- perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )"
+DEPEND="${COMMMON_DEPEND}
+ perl? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )"
+
+RDEPEND="${COMMON_DEPEND}"
src_unpack() {
unpack ${A}
@@ -29,8 +31,9 @@ src_unpack() {
-e "s!-Os -ggdb!!" \
-e "s!^all:.*!all: libstfl.a!" \
Makefile
-
- sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python2.4:" \
+
+ python_version
+ sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python${PYVER}:" \
python/Makefile.snippet
if ! use perl; then
@@ -42,20 +45,13 @@ src_unpack() {
}
src_compile() {
- if ! built_with_use sys-libs/ncurses unicode ; then
- eerror "For this package to compile you must"
- eerror "enable unicode use flag for ncurses."
- eerror "Please re-emerge ncurses with unicode"
- eerror "use flag."
- die
- fi
emake -j1 CC="$(tc-getCC)" || die "make failed"
}
src_install() {
local exdir="/usr/share/doc/${PF}/examples"
- dodir /usr/lib/python2.4/lib-dynload
+ dodir /usr/lib/python${PYVER}/lib-dynload
emake -j1 prefix="/usr" DESTDIR="${D}" install || die "make install failed"
dodoc README
diff --git a/dev-libs/stfl/stfl-0.18.ebuild b/dev-libs/stfl/stfl-0.18.ebuild
index 7b94b2c14f45..22998a8a67d6 100644
--- a/dev-libs/stfl/stfl-0.18.ebuild
+++ b/dev-libs/stfl/stfl-0.18.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.18.ebuild,v 1.2 2008/06/22 17:30:49 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.18.ebuild,v 1.3 2009/03/07 19:23:13 gentoofan23 Exp $
-inherit perl-module toolchain-funcs eutils multilib
+EAPI="2"
+inherit eutils multilib perl-module python toolchain-funcs
DESCRIPTION="A library which implements a curses-based widget set for text terminals"
HOMEPAGE="http://www.clifford.at/stfl/"
@@ -14,11 +15,11 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples perl ruby"
-DEPEND="sys-libs/ncurses
+DEPEND="sys-libs/ncurses[unicode]
perl? ( dev-lang/swig dev-lang/perl )
ruby? ( dev-lang/swig dev-lang/ruby )"
-RDEPEND="sys-libs/ncurses
+RDEPEND="sys-libs/ncurses[unicode]
perl? ( dev-lang/perl )
ruby? ( dev-lang/ruby )"
@@ -31,7 +32,8 @@ src_unpack() {
Makefile
epatch "${FILESDIR}/${P}-multilib.patch"
- sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python2.4:" \
+ python_version
+ sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python${PYVER}:" \
python/Makefile.snippet
if ! use perl; then
@@ -43,20 +45,13 @@ src_unpack() {
}
src_compile() {
- if ! built_with_use sys-libs/ncurses unicode ; then
- eerror "For this package to compile you must"
- eerror "enable unicode use flag for ncurses."
- eerror "Please re-emerge ncurses with unicode"
- eerror "use flag."
- die
- fi
emake -j1 CC="$(tc-getCC)" || die "make failed"
}
src_install() {
local exdir="/usr/share/doc/${PF}/examples"
- dodir /usr/lib/python2.4/lib-dynload
+ dodir /usr/lib/python${PYVER}/lib-dynload
emake -j1 prefix="/usr" DESTDIR="${D}" LIBDIR="$(get_libdir)" install || die "make install failed"
dodoc README
diff --git a/dev-libs/stfl/stfl-0.19.ebuild b/dev-libs/stfl/stfl-0.19.ebuild
index da5cefd2f242..cafad55a0bfc 100644
--- a/dev-libs/stfl/stfl-0.19.ebuild
+++ b/dev-libs/stfl/stfl-0.19.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.19.ebuild,v 1.3 2008/09/23 07:40:48 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.19.ebuild,v 1.4 2009/03/07 19:23:13 gentoofan23 Exp $
-inherit perl-module toolchain-funcs eutils multilib
+EAPI="2"
+inherit eutils multilib perl-module python toolchain-funcs
DESCRIPTION="A library which implements a curses-based widget set for text terminals"
HOMEPAGE="http://www.clifford.at/stfl/"
@@ -14,7 +15,7 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE="examples perl python ruby"
-COMMON_DEPEND="sys-libs/ncurses
+COMMON_DEPEND="sys-libs/ncurses[unicode]
perl? ( dev-lang/perl )
ruby? ( dev-lang/ruby )
python? ( dev-lang/python )"
@@ -25,16 +26,6 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}"
-pkg_setup() {
- if ! built_with_use sys-libs/ncurses unicode ; then
- eerror "For this package to compile you must"
- eerror "enable unicode use flag for ncurses."
- eerror "Please re-emerge ncurses with unicode"
- eerror "use flag."
- die
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -63,7 +54,6 @@ src_compile() {
}
src_install() {
-
emake prefix="/usr" DESTDIR="${D}" LIBDIR="$(get_libdir)" install || die "make install failed"
dodoc README