summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ucl/ucl-1.03.ebuild')
-rw-r--r--dev-libs/ucl/ucl-1.03.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-libs/ucl/ucl-1.03.ebuild b/dev-libs/ucl/ucl-1.03.ebuild
index 8d6f44b761a4..aa2fe5c980e6 100644
--- a/dev-libs/ucl/ucl-1.03.ebuild
+++ b/dev-libs/ucl/ucl-1.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucl/ucl-1.03.ebuild,v 1.3 2005/05/12 23:38:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucl/ucl-1.03.ebuild,v 1.4 2005/09/25 11:12:43 vapier Exp $
inherit flag-o-matic eutils
@@ -10,21 +10,16 @@ SRC_URI="http://www.oberhumer.com/opensource/ucl/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ppc64 ~ia64"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
src_compile() {
epunt_cxx #76771
-
- # Doing this b/c UCL will be included in the kernel
- # at some point, and will be fixed properly then
- # besides, this is lu_zero's build
- append-flags -fPIC
-
- econf || die
- emake CFLAGS_O= || die
+ econf --enable-shared || die
+ emake || die
}
src_install() {
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS NEWS README THANKS TODO
}