summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libreport')
-rw-r--r--dev-libs/libreport/ChangeLog9
-rw-r--r--dev-libs/libreport/files/libreport-2.0.13-automake-1.12.patch80
-rw-r--r--dev-libs/libreport/files/libreport-2.0.13-gentoo.patch295
-rw-r--r--dev-libs/libreport/libreport-2.0.13.ebuild93
4 files changed, 476 insertions, 1 deletions
diff --git a/dev-libs/libreport/ChangeLog b/dev-libs/libreport/ChangeLog
index f63a7857b73a..d4c448881348 100644
--- a/dev-libs/libreport/ChangeLog
+++ b/dev-libs/libreport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libreport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libreport/ChangeLog,v 1.12 2012/07/08 17:19:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libreport/ChangeLog,v 1.13 2012/09/22 20:12:48 tetromino Exp $
+
+*libreport-2.0.13 (22 Sep 2012)
+
+ 22 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libreport-2.0.13.ebuild, +files/libreport-2.0.13-automake-1.12.patch,
+ +files/libreport-2.0.13-gentoo.patch:
+ Version bump. Fix automake-1.12 problems with a proper patch.
08 Jul 2012; Justin Lecher <jlec@gentoo.org> libreport-2.0.10.ebuild:
Add fix for automake-1.12, #425268
diff --git a/dev-libs/libreport/files/libreport-2.0.13-automake-1.12.patch b/dev-libs/libreport/files/libreport-2.0.13-automake-1.12.patch
new file mode 100644
index 000000000000..4baaedd4d8eb
--- /dev/null
+++ b/dev-libs/libreport/files/libreport-2.0.13-automake-1.12.patch
@@ -0,0 +1,80 @@
+From cb7d7fe5b2daf4dac3b8a1616461a0c840e18b73 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 22 Sep 2012 03:06:03 -0400
+Subject: [PATCH] Fix automake-1.12 autoreconf issues.
+
+Need -Wno-portablity for '%'-style pattern rules in doc/Makefile.am
+
+Need AM_PROG_CC_C_O for src/cli/cli.c
+
+gettext-0.18.1.1's AM_GNU_GETTEXT requires AM_PROG_MKDIR_P, causing
+problems for automake-1.12.
+---
+ configure.ac | 8 +++-----
+ src/lib/Makefile.am | 2 +-
+ src/plugins/Makefile.am | 2 +-
+ 3 files changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index dd50bcf..3955689 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,7 @@ AC_INIT([libreport],
+ [crash-catcher@fedorahosted.org])
+
+ AC_CONFIG_MACRO_DIR([m4])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
++AM_INIT_AUTOMAKE([-Wall -Wno-portability -Werror foreign])
+ # Support silent build rules. Disable by either passing --disable-silent-rules
+ # to ./configure or passing V=1 to make
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
+@@ -11,8 +11,9 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
+ AM_SILENT_RULES([yes])
+
+ AC_DISABLE_STATIC
++AM_PROG_AR
+ AC_PROG_LIBTOOL
+-AC_PROG_CC
++AM_PROG_CC_C_O
+ AC_PROG_LN_S
+
+ AC_SYS_LARGEFILE
+@@ -33,9 +34,6 @@ GETTEXT_PACKAGE=libreport
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Package name for gettext])
+
+-AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.17])
+-
+ IT_PROG_INTLTOOL([0.35.0])
+
+ dnl ****** END ****************************************
+diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
+index 5befe7d..2c51931 100644
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -121,7 +121,7 @@ libreport_web_la_LIBADD = \
+ libreport.la
+
+ $(DESTDIR)/$(DEBUG_DUMPS_DIR):
+- $(mkdir_p) '$@'
++ $(MKDIR_P) '$@'
+ # no need to chmod it here
+ #chmod 1777 '$@'
+ install-data-local: $(DESTDIR)/$(DEBUG_DUMPS_DIR)
+diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
+index 3f9dfd7..795d198 100644
+--- a/src/plugins/Makefile.am
++++ b/src/plugins/Makefile.am
+@@ -40,7 +40,7 @@ EXTRA_DIST = \
+ report_Uploader.xml.in
+
+ $(DESTDIR)/$(DEBUG_INFO_DIR):
+- $(mkdir_p) '$@'
++ $(MKDIR_P) '$@'
+
+ reporter_upload_SOURCES = \
+ reporter-upload.c
+--
+1.7.12
+
diff --git a/dev-libs/libreport/files/libreport-2.0.13-gentoo.patch b/dev-libs/libreport/files/libreport-2.0.13-gentoo.patch
new file mode 100644
index 000000000000..89c6a17354a3
--- /dev/null
+++ b/dev-libs/libreport/files/libreport-2.0.13-gentoo.patch
@@ -0,0 +1,295 @@
+From 624d523361dcf8c10742cbcb1a017e21675002ff Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 22 Sep 2012 02:17:08 -0400
+Subject: [PATCH] Replace Fedora defaults with Gentoo ones, and disable code
+ not relevant for Gentoo
+
+Disable bugzilla and ureport plugins (they require Gentoo infrastructure
+changes). Fix libreport-web.pc to not rely on xmlrpc.pc, which Gentoo
+does not have.
+
+Disble mailx post-create by default to avoid "abrtd: 'post-create' ...
+exited with 141" errors.
+---
+ doc/Makefile.am | 2 -
+ doc/reporter-bugzilla.txt | 2 +-
+ libreport-web.pc.in | 6 +--
+ src/lib/dump_dir.c | 2 +-
+ src/plugins/Makefile.am | 83 ++------------------------------------
+ src/plugins/bugzilla.conf | 2 +-
+ src/plugins/mailx_event.conf | 2 +-
+ src/plugins/report_Bugzilla.conf | 2 +-
+ src/plugins/report_Bugzilla.xml.in | 4 +-
+ src/plugins/reporter-bugzilla.c | 2 +-
+ src/report-python/__init__.py | 4 +-
+ 11 files changed, 16 insertions(+), 95 deletions(-)
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 542fe4c..863b6d1 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -9,11 +9,9 @@ XMLTO_SILENT_0 = @echo " XMLTO " $@;
+
+ MAN1_TXT =
+ MAN1_TXT += report-cli.txt
+-MAN1_TXT += reporter-bugzilla.txt
+ MAN1_TXT += reporter-kerneloops.txt
+ MAN1_TXT += reporter-mailx.txt
+ MAN1_TXT += reporter-print.txt
+-MAN1_TXT += reporter-rhtsupport.txt
+ MAN1_TXT += reporter-upload.txt
+ MAN1_TXT += report.txt
+
+diff --git a/doc/reporter-bugzilla.txt b/doc/reporter-bugzilla.txt
+index 3cedf73..734d598 100644
+--- a/doc/reporter-bugzilla.txt
++++ b/doc/reporter-bugzilla.txt
+@@ -44,7 +44,7 @@ Configuration file lines should have 'PARAM = VALUE' format. The parameters are:
+ Password to Bugzilla account.
+
+ 'BugzillaURL'::
+- Bugzilla HTTP(S) address. (default: https://bugzilla.redhat.com)
++ Bugzilla HTTP(S) address. (default: https://bugs.gentoo.org/)
+
+ 'SSLVerify'::
+ Use yes/true/on/1 to verify server's SSL certificate. (default: yes)
+diff --git a/libreport-web.pc.in b/libreport-web.pc.in
+index c9af1d2..14505f8 100644
+--- a/libreport-web.pc.in
++++ b/libreport-web.pc.in
+@@ -6,7 +6,7 @@ includedir=@includedir@
+ Name: libreport
+ Description: Library providing network API for libreport
+ Version: @VERSION@
+-Requires: glib-2.0 libcurl libproxy-1.0 libxml-2.0 xmlrpc xmlrpc_client json btparser libreport
+-Libs: -L${libdir} -lreport-web
+-Cflags:
++Requires: glib-2.0 libcurl libproxy-1.0 libxml-2.0 json btparser libreport
++Libs: -L${libdir} @XMLRPC_LIBS@ @XMLRPC_CLIENT_LIBS@ -lreport-web
++Cflags: @XMLRPC_CFLAGS@ @XMLRPC_CLIENT_CFLAGS@
+
+diff --git a/src/lib/dump_dir.c b/src/lib/dump_dir.c
+index 0fc7da7..41e4f55 100644
+--- a/src/lib/dump_dir.c
++++ b/src/lib/dump_dir.c
+@@ -556,7 +556,7 @@ void dd_create_basic_files(struct dump_dir *dd, uid_t uid, const char *chroot_di
+ release = load_text_file("/etc/system-release",
+ DD_LOAD_TEXT_RETURN_NULL_ON_FAILURE);
+ if (!release)
+- release = load_text_file("/etc/redhat-release", /*flags:*/ 0);
++ release = load_text_file("/etc/gentoo-release", /*flags:*/ 0);
+ dd_save_text(dd, FILENAME_OS_RELEASE, release);
+ if (chroot_dir)
+ {
+diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
+index 967596f..3f9dfd7 100644
+--- a/src/plugins/Makefile.am
++++ b/src/plugins/Makefile.am
+@@ -1,36 +1,27 @@
+ pluginslibdir = $(PLUGINS_LIB_DIR)
+
+ bin_PROGRAMS = \
+- reporter-bugzilla \
+- reporter-rhtsupport \
+ reporter-kerneloops \
+ reporter-upload \
+ reporter-mailx \
+ reporter-print \
+- report \
+- reporter-ureport
++ report
+
+ pluginsconfdir = $(PLUGINS_CONF_DIR)
+
+ reportpluginsconfdir = $(REPORT_PLUGINS_CONF_DIR)
+
+ dist_reportpluginsconf_DATA = \
+- bugzilla.conf \
+- rhtsupport.conf \
+ mailx.conf
+
+ eventsdir = $(EVENTS_DIR)
+
+ dist_events_DATA = \
+- report_Bugzilla.xml \
+- report_Bugzilla.conf \
+ report_Logger.conf \
+ report_Logger.xml \
+ report_Mailx.xml \
+- report_RHTSupport.xml \
+ report_Kerneloops.xml \
+- report_Uploader.xml \
+- report_uReport.xml
++ report_Uploader.xml
+
+ @INTLTOOL_XML_RULE@
+
+@@ -39,74 +30,18 @@ eventsconfdir = $(EVENTS_CONF_DIR)
+ dist_eventsconf_DATA = \
+ mailx_event.conf \
+ print_event.conf \
+- bugzilla_event.conf \
+- rhtsupport_event.conf \
+ uploader_event.conf
+
+ EXTRA_DIST = \
+- report_Bugzilla.xml.in \
+- report_Bugzilla.conf \
+ report_Logger.conf \
+ report_Logger.xml.in \
+ report_Mailx.xml.in \
+- report_RHTSupport.xml.in \
+ report_Kerneloops.xml.in \
+- report_Uploader.xml.in \
+- report_uReport.xml.in
++ report_Uploader.xml.in
+
+ $(DESTDIR)/$(DEBUG_INFO_DIR):
+ $(mkdir_p) '$@'
+
+-reporter_bugzilla_SOURCES = \
+- reporter-bugzilla.c rhbz.c rhbz.h
+-reporter_bugzilla_CPPFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- -DBIN_DIR=\"$(bindir)\" \
+- -DCONF_DIR=\"$(CONF_DIR)\" \
+- -DLOCALSTATEDIR='"$(localstatedir)"' \
+- -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+- -DDEBUG_INFO_DIR=\"$(DEBUG_INFO_DIR)\" \
+- -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+- -DPLUGINS_CONF_DIR=\"$(REPORT_PLUGINS_CONF_DIR)\" \
+- $(GLIB_CFLAGS) \
+- $(LIBREPORT_CFLAGS) \
+- $(XMLRPC_CFLAGS) $(XMLRPC_CLIENT_CFLAGS) \
+- -D_GNU_SOURCE
+-reporter_bugzilla_LDADD = \
+- $(GLIB_LIBS) \
+- $(XMLRPC_LIBS) $(XMLRPC_CLIENT_LIBS) \
+- ../lib/libreport-web.la \
+- ../lib/libreport.la
+-
+-reporter_rhtsupport_SOURCES = \
+- abrt_rh_support.h abrt_rh_support.c \
+- reporter-rhtsupport.h \
+- reporter-rhtsupport-parse.c \
+- reporter-rhtsupport.c
+-reporter_rhtsupport_CPPFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- -DBIN_DIR=\"$(bindir)\" \
+- -DCONF_DIR=\"$(CONF_DIR)\" \
+- -DLOCALSTATEDIR='"$(localstatedir)"' \
+- -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+- -DDEBUG_INFO_DIR=\"$(DEBUG_INFO_DIR)\" \
+- -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+- -DPLUGINS_CONF_DIR=\"$(REPORT_PLUGINS_CONF_DIR)\" \
+- $(GLIB_CFLAGS) \
+- $(LIBREPORT_CFLAGS) \
+- $(XMLRPC_CFLAGS) $(XMLRPC_CLIENT_CFLAGS) \
+- $(LIBXML_CFLAGS) \
+- -D_GNU_SOURCE
+-reporter_rhtsupport_LDFLAGS = -ltar
+-reporter_rhtsupport_LDADD = \
+- $(GLIB_LIBS) \
+- $(LIBXML_LIBS) \
+- $(XMLRPC_LIBS) $(XMLRPC_CLIENT_LIBS) \
+- ../lib/libreport-web.la \
+- ../lib/libreport.la
+-
+ reporter_upload_SOURCES = \
+ reporter-upload.c
+ reporter_upload_CPPFLAGS = \
+@@ -200,16 +135,4 @@ report_CPPFLAGS = \
+ report_LDADD = \
+ ../lib/libreport.la
+
+-reporter_ureport_SOURCES = \
+- ureport.c
+-reporter_ureport_CPPFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- $(GLIB_CFLAGS) \
+- $(LIBREPORT_CFLAGS) \
+- -D_GNU_SOURCE
+-reporter_ureport_LDADD = \
+- ../lib/libreport.la \
+- ../lib/libreport-web.la
+-
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+diff --git a/src/plugins/bugzilla.conf b/src/plugins/bugzilla.conf
+index 18eba5a..f5afe6f 100644
+--- a/src/plugins/bugzilla.conf
++++ b/src/plugins/bugzilla.conf
+@@ -1,5 +1,5 @@
+ # Bugzilla URL
+-BugzillaURL = https://bugzilla.redhat.com/
++BugzillaURL = https://bugs.gentoo.org/
+ # yes means that ssl certificates will be checked
+ SSLVerify = yes
+ # your login has to exist, if you don have any, please create one
+diff --git a/src/plugins/mailx_event.conf b/src/plugins/mailx_event.conf
+index a8c5d11..1c07a73 100644
+--- a/src/plugins/mailx_event.conf
++++ b/src/plugins/mailx_event.conf
+@@ -1,3 +1,3 @@
+-EVENT=post-create reporter-mailx --notify-only -c /etc/libreport/plugins/mailx.conf
++# EVENT=post-create reporter-mailx --notify-only -c /etc/libreport/plugins/mailx.conf
+
+ EVENT=report_Mailx reporter-mailx
+diff --git a/src/plugins/report_Bugzilla.conf b/src/plugins/report_Bugzilla.conf
+index f1a77f5..bb2e651 100644
+--- a/src/plugins/report_Bugzilla.conf
++++ b/src/plugins/report_Bugzilla.conf
+@@ -1,4 +1,4 @@
+-Bugzilla_BugzillaURL = https://bugzilla.redhat.com
++Bugzilla_BugzillaURL = https://bugs.gentoo.org/
+ Bugzilla_Login =
+ Bugzilla_Password =
+ Bugzilla_SSLVerify = yes
+diff --git a/src/plugins/report_Bugzilla.xml.in b/src/plugins/report_Bugzilla.xml.in
+index 8151d32..acaf7fb 100644
+--- a/src/plugins/report_Bugzilla.xml.in
++++ b/src/plugins/report_Bugzilla.xml.in
+@@ -16,8 +16,8 @@
+ <_label>Bugzilla URL</_label>
+ <allow-empty>no</allow-empty>
+ <_description>Address of Bugzilla server</_description>
+- <default-value>https://bugzilla.redhat.com</default-value>
+- <_note-html>You can create bugzilla.redhat.com account &lt;a href="https://bugzilla.redhat.com/createaccount.cgi"&gt;here&lt;/a&gt;</_note-html>
++ <default-value>https://bugs.gentoo.org/</default-value>
++ <_note-html>You can create bugs.gentoo.org account &lt;a href="https://bugs.gentoo.org/createaccount.cgi"&gt;here&lt;/a&gt;</_note-html>
+ </option>
+ <option type="text" name="Bugzilla_Login">
+ <_label>User name</_label>
+diff --git a/src/plugins/reporter-bugzilla.c b/src/plugins/reporter-bugzilla.c
+index a3e8855..17a686d 100644
+--- a/src/plugins/reporter-bugzilla.c
++++ b/src/plugins/reporter-bugzilla.c
+@@ -34,7 +34,7 @@ static void set_settings(struct bugzilla_struct *b, map_string_h *settings)
+ environ = getenv("Bugzilla_BugzillaURL");
+ b->b_bugzilla_url = environ ? environ : get_map_string_item_or_empty(settings, "BugzillaURL");
+ if (!b->b_bugzilla_url[0])
+- b->b_bugzilla_url = "https://bugzilla.redhat.com";
++ b->b_bugzilla_url = "https://bugs.gentoo.org/";
+ b->b_bugzilla_xmlrpc = xasprintf("%s"XML_RPC_SUFFIX, b->b_bugzilla_url);
+
+ environ = getenv("Bugzilla_SSLVerify");
+diff --git a/src/report-python/__init__.py b/src/report-python/__init__.py
+index 9c5e6b3..7188392 100644
+--- a/src/report-python/__init__.py
++++ b/src/report-python/__init__.py
+@@ -21,8 +21,8 @@ from report.io import TextIO, GTKIO, NewtIO
+
+ import os
+
+-SYSTEM_RELEASE_PATHS = ["/etc/system-release","/etc/redhat-release"]
+-SYSTEM_RELEASE_DEPS = ["system-release", "redhat-release"]
++SYSTEM_RELEASE_PATHS = ["/etc/system-release","/etc/gentoo-release"]
++SYSTEM_RELEASE_DEPS = ["system-release", "gentoo-release"]
+
+ _hardcoded_default_product = ""
+ _hardcoded_default_version = ""
+--
+1.7.12
+
diff --git a/dev-libs/libreport/libreport-2.0.13.ebuild b/dev-libs/libreport/libreport-2.0.13.ebuild
new file mode 100644
index 000000000000..9f4e369e40db
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.0.13.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libreport/libreport-2.0.13.ebuild,v 1.1 2012/09/22 20:12:48 tetromino Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+
+inherit autotools eutils python user
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://fedorahosted.org/abrt/"
+SRC_URI="https://fedorahosted.org/released/abrt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/btparser-0.18
+ >=dev-libs/glib-2.21:2
+ dev-libs/json-c
+ dev-libs/libtar
+ dev-libs/libxml2:2
+ dev-libs/newt
+ dev-libs/nss
+ dev-libs/xmlrpc-c
+ net-libs/libproxy
+ net-misc/curl[ssl]
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.3.12:3
+ x11-misc/xdg-utils"
+RDEPEND="${COMMON_DEPEND}
+ || ( gnome-base/gnome-keyring >=kde-base/kwalletd-4.8 )"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ # Replace redhat- and fedora-specific defaults with gentoo ones, and disable
+ # code that requires gentoo infra support.
+ epatch "${FILESDIR}/${PN}-2.0.13-gentoo.patch"
+
+ # Modify uploader_event so that the gui recognizes it
+ epatch "${FILESDIR}/${PN}-2.0.7-uploader_event-syntax.patch"
+
+ # automake-1.12
+ epatch "${FILESDIR}/${PN}-2.0.13-automake-1.12.patch"
+
+ python_clean_py-compile_files
+
+ mkdir -p m4
+ eautoreconf
+}
+
+src_configure() {
+ ECONF="--disable-bodhi
+ --localstatedir=${EPREFIX}/var"
+ # --disable-debug enables debug!
+ use debug && ECONF="${ECONF} --enable-debug"
+ econf ${ECONF}
+}
+
+src_install() {
+ default
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}
+
+pkg_postinst() {
+ python_mod_optimize report reportclient
+}
+
+pkg_postrm() {
+ python_mod_cleanup report reportclient
+}