summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpeas/libpeas-1.6.2-r1.ebuild')
-rw-r--r--dev-libs/libpeas/libpeas-1.6.2-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild b/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild
deleted file mode 100644
index 3e2f458efbd0..000000000000
--- a/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/libpeas-1.6.2-r1.ebuild,v 1.6 2013/02/02 22:26:12 ago Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit eutils gnome2 multilib python-single-r1 virtualx
-
-DESCRIPTION="A GObject plugins library"
-HOMEPAGE="http://developer.gnome.org/libpeas/stable/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-IUSE="gjs +gtk glade +python seed"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
-
-RDEPEND=">=dev-libs/glib-2.32:2
- >=dev-libs/gobject-introspection-0.10.1
- gjs? ( >=dev-libs/gjs-1.31.11 )
- glade? ( >=dev-util/glade-3.9.1:3.10 )
- gtk? ( >=x11-libs/gtk+-3:3[introspection] )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-3.0.0:3[${PYTHON_USEDEP}] )
- seed? ( >=dev-libs/seed-2.91.91 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- >=sys-devel/gettext-0.17"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- G2CONF="${G2CONF}
- $(use_enable gjs)
- $(use_enable glade glade-catalog)
- $(use_enable gtk)
- $(use_enable python)
- $(use_enable seed)
- --disable-deprecation
- --disable-static"
- # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
- # What do we do about gdb, valgrind, gcov, etc?
-
- gnome2_src_prepare
-}
-
-src_test() {
- # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
- # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
- # To reproduce:
- # >>> from gi.repository import Gtk
- # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
- # This should return True, it returns False for Xvfb
- Xemake check
-}