summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libindicate/libindicate-0.6.1-r300.ebuild')
-rw-r--r--dev-libs/libindicate/libindicate-0.6.1-r300.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libindicate/libindicate-0.6.1-r300.ebuild b/dev-libs/libindicate/libindicate-0.6.1-r300.ebuild
new file mode 100644
index 000000000000..c0da735220d7
--- /dev/null
+++ b/dev-libs/libindicate/libindicate-0.6.1-r300.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-0.6.1-r300.ebuild,v 1.1 2011/11/26 18:10:45 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+PV_vala_version=0.14
+
+DESCRIPTION="A library to raise flags on DBus for other components of the desktop to pick up and visualize"
+HOMEPAGE="http://launchpad.net/libindicate"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/dbus-glib-0.76
+ >=dev-libs/glib-2.18:2
+ >=dev-libs/libdbusmenu-0.3.97[introspection?]
+ dev-libs/libxml2:2
+ x11-libs/gtk+:3
+ introspection? ( dev-libs/gobject-introspection )"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ app-text/gnome-doc-utils
+ dev-util/gtk-doc-am
+ dev-util/pkgconfig
+ dev-lang/vala:${PV_vala_version}[vapigen]
+ !<${CATEGORY}/${PN}-0.6.1-r201"
+
+RESTRICT="test" # for -no-mono.patch
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-mono.patch
+
+ sed -i -e 's:-Werror::' {examples,libindicate,libindicate-gtk}/Makefile.{am,in} || die
+
+ # for slotted dev-lang/vala
+ sed -i -e "s:vapigen:vapigen-${PV_vala_version}:" configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # note: --disable-python to avoid automagic gtk+-2.0 usage
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python \
+ --with-gtk=3 \
+ --with-html-dir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+}