summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libiconv/libiconv-1.10.ebuild')
-rw-r--r--dev-libs/libiconv/libiconv-1.10.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libiconv/libiconv-1.10.ebuild b/dev-libs/libiconv/libiconv-1.10.ebuild
new file mode 100644
index 000000000000..fb2e24ab5f9f
--- /dev/null
+++ b/dev-libs/libiconv/libiconv-1.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/libiconv-1.10.ebuild,v 1.1 2005/09/04 19:03:16 flameeyes Exp $
+
+inherit eutils multilib flag-o-matic autotools libtool
+
+DESCRIPTION="GNU charset conversion library for libc which doesn't implement it"
+SRC_URI="mirror://gnu/libiconv/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/libiconv/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="build"
+
+DEPEND="virtual/libc
+ !sys-libs/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This patch is needed as libiconv 1.10 provides (and uses) new functions
+ # and they are not present in the old libiconv.so, and this breaks the
+ # ${DESTDIR} != ${prefix} that we use. It's a problem for Solaris, but we
+ # don't have to deal with it for now.
+ epatch ${FILESDIR}/${P}-link.patch
+
+ # Make sure that libtool support is updated to link "the linux way" on
+ # FreeBSD.
+ elibtoolize
+}
+
+src_compile() {
+ # Filter -static as it breaks compilation
+ filter-ldflags -static
+
+ # Install in /lib as utils installed in /lib like gnutar
+ # can depend on this
+
+ # Disable NLS support because that creates a circular dependency
+ # between libiconv and gettext
+
+ econf \
+ --disable-nls \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
+
+ # Move static libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv ${D}/usr/$(get_libdir)/*.so* ${D}/$(get_libdir)
+ gen_usr_ldscript libiconv.so
+ gen_usr_ldscript libcharset.so
+
+ use build && rm -rf ${D}/usr
+
+ preserve_old_lib /lib/$(get_libdir)/libiconv.so.4
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /lib/$(get_libdir)/libiconv.so.4
+}