summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libexplain/libexplain-0.47.ebuild')
-rw-r--r--dev-libs/libexplain/libexplain-0.47.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-libs/libexplain/libexplain-0.47.ebuild b/dev-libs/libexplain/libexplain-0.47.ebuild
deleted file mode 100644
index babb54906054..000000000000
--- a/dev-libs/libexplain/libexplain-0.47.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-0.47.ebuild,v 1.2 2011/11/27 17:01:06 jlec Exp $
-
-EAPI=4
-inherit autotools eutils
-
-MY_P="${P}.D001"
-
-DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
-HOMEPAGE="http://libexplain.sourceforge.net/"
-SRC_URI="http://libexplain.sourceforge.net/${MY_P}.tar.gz
- http://dev.gentoo.org/~radhermit/distfiles/${P}-parallel-make.patch.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-3"
-IUSE="static-libs"
-
-DEPEND="
- >=sys-kernel/linux-headers-2.6.35
- sys-libs/libcap
- >=sys-libs/glibc-2.11"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-src_prepare() {
- # Portage incompatible test
- sed \
- -e '/t0524a/d' \
- -e '/t0363a/d' \
- -i Makefile.in || die
-
- cp "${S}"/etc/configure.ac "${S}"
- epatch "${FILESDIR}"/${PN}-0.45-configure.patch \
- "${WORKDIR}"/${P}-parallel-make.patch
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -exec rm -f '{}' +
-}