summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcroco/libcroco-0.6.4.ebuild')
-rw-r--r--dev-libs/libcroco/libcroco-0.6.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libcroco/libcroco-0.6.4.ebuild b/dev-libs/libcroco/libcroco-0.6.4.ebuild
new file mode 100644
index 000000000000..fca780d1c4e3
--- /dev/null
+++ b/dev-libs/libcroco/libcroco-0.6.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcroco/libcroco-0.6.4.ebuild,v 1.1 2012/02/13 10:18:53 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
+HOMEPAGE="http://git.gnome.org/browse/libcroco/"
+
+LICENSE="LGPL-2"
+SLOT="0.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc test"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-libs/libxml2-2.4.23"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-static"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+}