summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/icu/icu-49.1.1-r1.ebuild')
-rw-r--r--dev-libs/icu/icu-49.1.1-r1.ebuild97
1 files changed, 0 insertions, 97 deletions
diff --git a/dev-libs/icu/icu-49.1.1-r1.ebuild b/dev-libs/icu/icu-49.1.1-r1.ebuild
deleted file mode 100644
index 11c991ef51cf..000000000000
--- a/dev-libs/icu/icu-49.1.1-r1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-49.1.1-r1.ebuild,v 1.11 2012/06/05 20:57:37 jer Exp $
-
-EAPI="4"
-
-inherit eutils versionator flag-o-matic
-
-MAJOR_VERSION="$(get_version_component_range 1)"
-if [[ "${PV}" =~ ^[[:digit:]]+_rc[[:digit:]]*$ ]]; then
- MINOR_VERSION="0"
-else
- MINOR_VERSION="$(get_version_component_range 2)"
-fi
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-
-BASE_URI="http://download.icu-project.org/files/icu4c/${PV/_/}"
-SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
-DOCS_ARCHIVE="icu4c-${PV//./_}-docs.zip"
-
-SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
- doc? ( ${BASE_URI}/${DOCS_ARCHIVE} )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="debug doc examples static-libs"
-
-DEPEND="doc? ( app-arch/unzip )"
-RDEPEND=""
-
-S="${WORKDIR}/${PN}/source"
-
-QA_DT_NEEDED="/usr/lib.*/libicudata\.so\.${MAJOR_VERSION}\.${MINOR_VERSION}.*"
-
-src_unpack() {
- unpack "${SRC_ARCHIVE}"
- if use doc; then
- mkdir docs
- pushd docs > /dev/null
- unpack "${DOCS_ARCHIVE}"
- popd > /dev/null
- fi
-}
-
-src_prepare() {
- # Do not hardcode flags into icu-config.
- # https://ssl.icu-project.org/trac/ticket/6102
- local variable
- for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
- done
-
- epatch "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
- epatch "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
- epatch "${FILESDIR}/${P}-regex.patch"
- epatch "${FILESDIR}/${P}-bsd.patch"
-}
-
-src_configure() {
- # Fails without this on hppa/s390/sparc
- if use hppa || use s390 || use sparc; then
- append-flags "-DU_IS_BIG_ENDIAN=1"
- fi
-
- econf \
- $(use_enable debug) \
- $(use_enable examples samples) \
- $(use_enable static-libs static)
-}
-
-src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- emake -j1 check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dohtml ../readme.html
- dodoc ../unicode-license.txt
- if use doc; then
- insinto /usr/share/doc/${PF}/html/api
- doins -r "${WORKDIR}/docs/"*
- fi
-}