summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/grantlee')
-rw-r--r--dev-libs/grantlee/ChangeLog9
-rw-r--r--dev-libs/grantlee/grantlee-0.4.0.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-libs/grantlee/ChangeLog b/dev-libs/grantlee/ChangeLog
index e0e258f8c7c5..0a6c1fdb63de 100644
--- a/dev-libs/grantlee/ChangeLog
+++ b/dev-libs/grantlee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/grantlee
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.26 2013/04/02 20:56:08 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.27 2014/02/05 17:16:43 kensington Exp $
+
+*grantlee-0.4.0 (05 Feb 2014)
+
+ 05 Feb 2014; Michael Palimaka <kensington@gentoo.org> +grantlee-0.4.0.ebuild:
+ Version bump.
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> grantlee-0.3.0.ebuild:
Stable for ppc64, wrt bug #462890
diff --git a/dev-libs/grantlee/grantlee-0.4.0.ebuild b/dev-libs/grantlee/grantlee-0.4.0.ebuild
new file mode 100644
index 000000000000..3558423b1992
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-0.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.4.0.ebuild,v 1.1 2014/02/05 17:16:43 kensington Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="http://www.gitorious.org/grantlee/pages/Home"
+SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+"
+DEPEND="${RDEPEND}
+ doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
+ test? ( dev-qt/qttest:4 )
+"
+
+# Some tests fail
+RESTRICT="test"
+
+DOCS=( AUTHORS CHANGELOG GOALS README )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}/apidox/" )
+
+ cmake-utils_src_install
+}