summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/g-wrap/g-wrap-1.9.6-r1.ebuild')
-rw-r--r--dev-libs/g-wrap/g-wrap-1.9.6-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/g-wrap/g-wrap-1.9.6-r1.ebuild b/dev-libs/g-wrap/g-wrap-1.9.6-r1.ebuild
new file mode 100644
index 000000000000..3a155b3c154e
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.9.6-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/g-wrap-1.9.6-r1.ebuild,v 1.1 2007/01/24 17:15:21 hkbst Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+HOMEPAGE="http://www.nongnu.org/g-wrap/"
+SRC_URI="http://download.savannah.gnu.org/releases/g-wrap/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="=dev-scheme/guile-1.6*
+ =dev-libs/glib-2*"
+# seems not to work. g-wrap builds its own libffi-4.0.1
+# dev-libs/libffi
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}_glib_automagic.patch
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+#looks like parallel build and install fails occasionally
+src_compile() {
+ econf --with-glib
+ emake -j1 || die 'make failed'
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}