summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/eb/eb-4.1.3.ebuild')
-rw-r--r--dev-libs/eb/eb-4.1.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/eb/eb-4.1.3.ebuild b/dev-libs/eb/eb-4.1.3.ebuild
new file mode 100644
index 000000000000..b7fd94ea5c3c
--- /dev/null
+++ b/dev-libs/eb/eb-4.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/eb-4.1.3.ebuild,v 1.1 2005/03/19 11:24:10 matsuu Exp $
+
+inherit eutils
+
+IUSE="nls ipv6 threads"
+
+DESCRIPTION="EB is a C library and utilities for accessing CD-ROM books"
+HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/eb/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/misc/eb/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )"
+
+src_compile () {
+
+ econf \
+ --with-pkgdocdir=/usr/share/doc/${PF}/html \
+ `use_enable nls` \
+ `use_enable threads pthread` \
+ `use_enable ipv6` || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL* NEWS README*
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "If you are upgrading from <app-dicts/eb-4,"
+ einfo "you may need to rebuild applications depending on eb."
+ einfo
+}