summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dvutil/dvutil-0.13.15-r2.ebuild')
-rw-r--r--dev-libs/dvutil/dvutil-0.13.15-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/dvutil/dvutil-0.13.15-r2.ebuild b/dev-libs/dvutil/dvutil-0.13.15-r2.ebuild
new file mode 100644
index 000000000000..e4067e0662ab
--- /dev/null
+++ b/dev-libs/dvutil/dvutil-0.13.15-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvutil/dvutil-0.13.15-r2.ebuild,v 1.1 2005/05/20 12:57:46 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="dvutil provides some general C++ utility classes for files, directories, dates, property lists, reference counted pointers, number conversion etc. "
+HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvutil/html/"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvutil/download/dvutil-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix-underquoted-m4.diff
+
+ sed -i 's|^\(SUBDIRS =.*\)doc\(.*\)$|\1\2|' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc ; then
+ doman doc/man/*/*.[1-9]
+ dohtml -r doc/html/*
+ fi
+}