summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild')
-rw-r--r--dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild b/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild
new file mode 100644
index 000000000000..2ed4bb7f93e6
--- /dev/null
+++ b/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.32_pre20080829.ebuild,v 1.1 2008/08/29 17:08:33 hollow Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A minimal libc"
+HOMEPAGE="http://www.fefe.de/dietlibc/"
+SRC_URI="http://people.linux-vserver.org/~hollow/dietlibc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+
+DIETHOME=/usr/diet
+
+pkg_setup() {
+ # Replace sparc64 related C[XX]FLAGS (see bug #45716)
+ use sparc && replace-sparc64-flags
+
+ # gcc-hppa suffers support for SSP, compilation will fail
+ use hppa && strip-unsupported-flags
+
+ # debug flags
+ use debug && append-flags -g
+
+ # Makefile does not append CFLAGS
+ append-flags -nostdinc -W -Wall -Wextra -Wchar-subscripts \
+ -Wmissing-prototypes -Wmissing-declarations -Wno-switch \
+ -Wno-unused -Wredundant-decls
+}
+
+src_compile() {
+ emake prefix=${DIETHOME} CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ emake prefix=${DIETHOME} DESTDIR="${D}" install || die "make install failed"
+ dobin "${D}"${DIETHOME}/bin/* || die "dobin failed"
+ doman "${D}"${DIETHOME}/man/*/* || die "doman failed"
+ rm -r "${D}"${DIETHOME}/{man,bin}
+ dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING
+}