summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/pugs/ChangeLog8
-rw-r--r--dev-lang/pugs/files/digest-pugs-6.2.102
-rw-r--r--dev-lang/pugs/files/digest-pugs-6.2.123
-rw-r--r--dev-lang/pugs/files/pugs-6.2.12-build_dir.patch11
-rw-r--r--dev-lang/pugs/pugs-6.2.12.ebuild37
5 files changed, 60 insertions, 1 deletions
diff --git a/dev-lang/pugs/ChangeLog b/dev-lang/pugs/ChangeLog
index a39882248648..9f9b474335ac 100644
--- a/dev-lang/pugs/ChangeLog
+++ b/dev-lang/pugs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/pugs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/ChangeLog,v 1.9 2006/05/22 19:50:16 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/ChangeLog,v 1.10 2006/08/13 15:56:14 yuval Exp $
+
+*pugs-6.2.12 (13 Aug 2006)
+
+ 13 Aug 2006; <yuval@gentoo.org> +files/pugs-6.2.12-build_dir.patch,
+ +pugs-6.2.12.ebuild:
+ Version bump (bug #141027). Thanks Tobias Gödderz!
22 May 2006; <mcummings@gentoo.org> -pugs-6.2.9.ebuild:
Cleaning up
diff --git a/dev-lang/pugs/files/digest-pugs-6.2.10 b/dev-lang/pugs/files/digest-pugs-6.2.10
index 5646ba2f146f..1cfcd0d612ad 100644
--- a/dev-lang/pugs/files/digest-pugs-6.2.10
+++ b/dev-lang/pugs/files/digest-pugs-6.2.10
@@ -1 +1,3 @@
MD5 0c2151d0a49b1b53022b9b685d6977ae Perl6-Pugs-6.2.10.tar.gz 2394516
+RMD160 719f08005fa0de04504e3b8fec6e916e112e5efb Perl6-Pugs-6.2.10.tar.gz 2394516
+SHA256 0d603f961ac35f87c6b905e3fae58f7f7cb76bbe8ab8d0f77597da70312b52dc Perl6-Pugs-6.2.10.tar.gz 2394516
diff --git a/dev-lang/pugs/files/digest-pugs-6.2.12 b/dev-lang/pugs/files/digest-pugs-6.2.12
new file mode 100644
index 000000000000..aef9252feea0
--- /dev/null
+++ b/dev-lang/pugs/files/digest-pugs-6.2.12
@@ -0,0 +1,3 @@
+MD5 99e15186586cbb8ce607ac74b748d072 Perl6-Pugs-6.2.12.tar.gz 2693459
+RMD160 d1a1476111f451bea032f13ebd6dc4000b149e4a Perl6-Pugs-6.2.12.tar.gz 2693459
+SHA256 183a69ce59feff34fa5b0bf755f5b5d4f1e319b568f7a6c9dd45d4c835004373 Perl6-Pugs-6.2.12.tar.gz 2693459
diff --git a/dev-lang/pugs/files/pugs-6.2.12-build_dir.patch b/dev-lang/pugs/files/pugs-6.2.12-build_dir.patch
new file mode 100644
index 000000000000..8974c7a56d44
--- /dev/null
+++ b/dev-lang/pugs/files/pugs-6.2.12-build_dir.patch
@@ -0,0 +1,11 @@
+--- Makefile.PL.old 2006-07-19 14:00:04.475243250 +0200
++++ Makefile.PL 2006-07-19 14:00:24.556498250 +0200
+@@ -348,7 +348,7 @@
+ my $icuflags = parrot_config($base, $parrot_config, 'icu_shared');
+ my $include_path = parrot_config($base, $parrot_config, 'prefix') . parrot_config($base, $parrot_config, 'inc');
+ my $rpath_blib = parrot_config($base, $parrot_config, 'rpath_blib');
+- my $build_dir = parrot_config($base, $parrot_config, 'top_builddir', 'build_dir');
++ my $build_dir = $ENV{PARROT_PATH};
+ my $is_shared = parrot_config($base, $parrot_config, 'parrot_is_shared');
+
+ # Convert flags to -optc-*,etc, to pass through ghc. c/ompiler l/inker
diff --git a/dev-lang/pugs/pugs-6.2.12.ebuild b/dev-lang/pugs/pugs-6.2.12.ebuild
new file mode 100644
index 000000000000..0a6610232c68
--- /dev/null
+++ b/dev-lang/pugs/pugs-6.2.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pugs/pugs-6.2.12.ebuild,v 1.1 2006/08/13 15:56:14 yuval Exp $
+
+inherit perl-module multilib eutils
+
+MY_P="Perl6-Pugs-${PV}"
+S="${WORKDIR}/-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Pugs is an implementation of Perl 6, written in Haskell"
+HOMEPAGE="http://pugscode.org/"
+SRC_URI="mirror://cpan/authors/id/A/AU/AUTRIJUS/${MY_P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE=""
+
+DEPEND="dev-perl/Term-ReadLine-Perl
+ || ( >=dev-lang/ghc-bin-6.4.1 >=dev-lang/ghc-6.4.1 )
+ >=dev-lang/parrot-0.4.5"
+#not yet supported because the 0.9.8 version does not work with ghc-6.4 that is required for pugs
+
+export PARROT_PATH="/usr/$(get_libdir)/parrot"
+#this links against parrot and perl5 - if threads was used to compile perl5 this is not supported here
+export PUGS_EMBED="parrot perl5"
+#del upon ghc-6.4.1 release
+export GHCRTS='-A200M'
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-build_dir.patch
+}