summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/v8-3.0.7.ebuild7
-rw-r--r--dev-lang/v8/v8-9999.ebuild7
3 files changed, 15 insertions, 5 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index a5fe9b310942..dda2e9f26f2f 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.29 2011/01/21 07:46:13 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.30 2011/01/22 10:05:32 phajdan.jr Exp $
+
+ 22 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-3.0.7.ebuild,
+ v8-9999.ebuild:
+ Fix src_test, bug #352374 by Nikoli <nikoli@lavabit.com>.
*v8-3.0.7 (21 Jan 2011)
diff --git a/dev-lang/v8/v8-3.0.7.ebuild b/dev-lang/v8/v8-3.0.7.ebuild
index d3d5b2496cde..d89bbab91a65 100644
--- a/dev-lang/v8/v8-3.0.7.ebuild
+++ b/dev-lang/v8/v8-3.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.7.ebuild,v 1.1 2011/01/21 07:46:13 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.7.ebuild,v 1.2 2011/01/22 10:05:32 phajdan.jr Exp $
EAPI="2"
@@ -86,5 +86,8 @@ src_install() {
}
src_test() {
- tools/test.py --no-build -p dots || die
+ # Make sure we use the libv8.so from our build directory,
+ # and not the /usr/lib one (it may be missing if we are
+ # installing for the first time or upgrading), see bug #352374.
+ LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
}
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 568ed4ae9af9..4d24265d14d7 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.4 2011/01/14 12:44:43 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.5 2011/01/22 10:05:32 phajdan.jr Exp $
EAPI="2"
@@ -84,7 +84,10 @@ src_install() {
}
src_test() {
- tools/test.py --no-build -p dots || die
+ # Make sure we use the libv8.so from our build directory,
+ # and not the /usr/lib one (it may be missing if we are
+ # installing for the first time or upgrading), see bug #352374.
+ LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
}
pkg_postinst() {