summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/v8/v8-3.6.6.5.ebuild')
-rw-r--r--dev-lang/v8/v8-3.6.6.5.ebuild26
1 files changed, 23 insertions, 3 deletions
diff --git a/dev-lang/v8/v8-3.6.6.5.ebuild b/dev-lang/v8/v8-3.6.6.5.ebuild
index f252e409d93c..8a9431ae64f9 100644
--- a/dev-lang/v8/v8-3.6.6.5.ebuild
+++ b/dev-lang/v8/v8-3.6.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.6.6.5.ebuild,v 1.1 2011/10/21 02:29:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.6.6.5.ebuild,v 1.2 2011/10/22 11:44:36 phajdan.jr Exp $
EAPI="3"
@@ -8,8 +8,6 @@ PYTHON_DEPEND="2:2.6"
inherit eutils multilib pax-utils python toolchain-funcs
-GYP_REV="1066"
-
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
SRC_URI="http://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.bz2"
@@ -21,6 +19,7 @@ IUSE=""
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -47,6 +46,7 @@ src_compile() {
mytarget=${myarch}.release
if [[ ${PV} == "9999" ]]; then
+ subversion_wc_info
soname_version="${PV}-${ESVN_WC_REVISION}"
else
soname_version="${PV}"
@@ -92,3 +92,23 @@ src_install() {
dodoc AUTHORS ChangeLog || die
}
+
+pkg_preinst() {
+ local preserved_candidates="$(find /usr/$(get_libdir) -maxdepth 1 -name libv8-\*$(get_libname))"
+ preserved_libs=""
+ for candidate in ${preserved_candidates}; do
+ if [[ -f "${D}/usr/$(get_libdir)/`basename ${candidate}`" ]]; then
+ continue
+ fi
+ preserved_libs+=" ${candidate}"
+ done
+ if [[ "${preserved_libs}" != "" ]]; then
+ preserve_old_lib ${preserved_libs}
+ fi
+}
+
+pkg_postinst() {
+ if [[ "${preserved_libs}" != "" ]]; then
+ preserve_old_lib_notify ${preserved_libs}
+ fi
+}