summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rakudo/rakudo-2010.04.ebuild')
-rw-r--r--dev-lang/rakudo/rakudo-2010.04.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/rakudo/rakudo-2010.04.ebuild b/dev-lang/rakudo/rakudo-2010.04.ebuild
new file mode 100644
index 000000000000..b8d0707630e7
--- /dev/null
+++ b/dev-lang/rakudo/rakudo-2010.04.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rakudo/rakudo-2010.04.ebuild,v 1.1 2010/04/25 07:44:05 tove Exp $
+
+EAPI=3
+
+PARROT_VERSION="2.3.0"
+inherit eutils multilib
+
+DESCRIPTION="A Perl 6 implementation built on the Parrot virtual machine"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://cloud.github.com/downloads/${PN}/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+#DEPEND=">=dev-lang/perl-5.10"
+DEPEND="dev-lang/perl"
+RDEPEND="~dev-lang/parrot-${PARROT_VERSION}[unicode]"
+
+src_configure() {
+ perl Configure.pl || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README docs/ChangeLog docs/ROADMAP || die
+
+ if use doc; then
+ dohtml -A svg docs/architecture.html docs/architecture.svg || die
+ dodoc docs/*.pod || die
+ docinto announce
+ dodoc docs/announce/* || die
+ fi
+}