summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-2.11.0.ebuild (renamed from dev-lang/R/R-2.10.0.ebuild)33
-rw-r--r--dev-lang/R/R-2.7.2.ebuild159
-rw-r--r--dev-lang/R/R-2.8.1.ebuild157
4 files changed, 22 insertions, 335 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 449b6312a82b..9a2f1a4e70b3 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.172 2010/04/16 20:24:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.173 2010/04/28 00:28:47 bicatali Exp $
+
+*R-2.11.0 (28 Apr 2010)
+
+ 28 Apr 2010; Sébastien Fabbro <bicatali@gentoo.org> -R-2.7.2.ebuild,
+ -R-2.8.1.ebuild, -R-2.10.0.ebuild, +R-2.11.0.ebuild:
+ Version bump
16 Apr 2010; Raúl Porcel <armin76@gentoo.org> R-2.10.1.ebuild:
alpha/ia64/sparc stable wrt #306747
diff --git a/dev-lang/R/R-2.10.0.ebuild b/dev-lang/R/R-2.11.0.ebuild
index 99fa80cc7437..59ccb16f4e65 100644
--- a/dev-lang/R/R-2.10.0.ebuild
+++ b/dev-lang/R/R-2.11.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.10.0.ebuild,v 1.2 2009/12/26 17:32:26 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.11.0.ebuild,v 1.1 2010/04/28 00:28:47 bicatali Exp $
EAPI=2
inherit eutils flag-o-matic bash-completion versionator
@@ -42,10 +42,14 @@ RDEPEND="${CDEPEND}
app-arch/zip
java? ( >=virtual/jre-1.5 )"
-R_HOME=/usr/$(get_libdir)/${PN}
+RESTRICT="minimal? ( test )"
+
+R_DIR=/usr/$(get_libdir)/${PN}
pkg_setup() {
filter-ldflags -Wl,-Bdirect -Bdirect
+ # avoid using existing R installation
+ unset R_HOME
}
src_prepare() {
@@ -58,7 +62,7 @@ src_prepare() {
# fix Rscript
sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_HOME}\"':" \
+ -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
src/unix/Makefile.in || die "sed unix Makefile failed"
# fix HTML links to manual (bug #273957)
@@ -72,16 +76,15 @@ src_prepare() {
export R_BROWSER="$(type -p xdg-open)"
export R_PDFVIEWER="$(type -p xdg-open)"
fi
- use perl && export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
+ use perl && \
+ export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
}
src_configure() {
econf \
- --disable-rpath \
--enable-R-profiling \
--enable-memory-profiling \
--enable-R-shlib \
- --enable-linux-lfs \
--with-system-zlib \
--with-system-bzlib \
--with-system-pcre \
@@ -103,7 +106,7 @@ src_configure() {
src_compile(){
emake || die "emake failed"
RMATH_V=0.0.0
- emake -j1 -C src/nmath/standalone \
+ emake -C src/nmath/standalone \
libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
|| die "emake math library failed"
if use doc; then
@@ -112,12 +115,6 @@ src_compile(){
fi
}
-src_test() {
- # we need to unset R_HOME otherwise some of the diff based
- # tests fail due to warnings in the output
- R_HOME="" emake -j1 check || die "Some of the tests failed"
-}
-
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
@@ -128,7 +125,7 @@ src_install() {
fi
# standalone math lib install (-j1 basically harmless)
- emake -j1 \
+ emake \
-C src/nmath/standalone \
DESTDIR="${D}" install \
|| die "emake install math library failed"
@@ -141,14 +138,14 @@ src_install() {
# env file
cat > 99R <<-EOF
- LDPATH=${R_HOME}/lib
- R_HOME=${R_HOME}
+ LDPATH=${R_DIR}/lib
+ R_HOME=${R_DIR}
EOF
doenvd 99R || die "doenvd failed"
dobashcompletion "${WORKDIR}"/R.bash_completion
}
-pkg_config() {
+pkg_postinst() {
if use java; then
einfo "Re-initializing java paths for ${P}"
R CMD javareconf
diff --git a/dev-lang/R/R-2.7.2.ebuild b/dev-lang/R/R-2.7.2.ebuild
deleted file mode 100644
index dc37efb32a6b..000000000000
--- a/dev-lang/R/R-2.7.2.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.7.2.ebuild,v 1.13 2009/12/26 17:32:26 pva Exp $
-
-EAPI=2
-inherit fortran flag-o-matic bash-completion versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="doc java jpeg lapack minimal nls png readline tk X cairo"
-
-# common depends
-CDEPEND="dev-lang/perl
- >=dev-libs/libpcre-7.3
- app-arch/bzip2
- virtual/blas
- app-text/ghostscript-gpl
- cairo? ( x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
- readline? ( sys-libs/readline )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base
- || ( dev-texlive/texlive-fontsrecommended
- app-text/ptex ) )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-R_HOME=/usr/$(get_libdir)/${PN}
-
-pkg_setup() {
- FORTRAN="gfortran ifc g77"
- fortran_pkg_setup
- export FFLAGS="${FFLAGS:--O2}"
- [[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
- export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-javareconf.patch
- epatch "${FILESDIR}"/${PN}-2.7.1-test-fix.patch
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-}
-
-src_test() {
- # we need to unset R_HOME otherwise some of the diff based
- # tests fail due to warnings in the output
- R_HOME="" make check || die "Some of the tests failed"
-}
-
-src_configure() {
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
- || die "sed failed"
-
- # fix Rscript
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_HOME}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
-
- econf \
- --enable-R-profiling \
- --enable-memory-profiling \
- --enable-R-shlib \
- --enable-linux-lfs \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake info pdf || die "emake docs failed"
- fi
-
- RMATH_V=0.0.0
- emake -j1 -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
-}
-
-src_install() {
- # -j1 because creates various dirs sequentially (hit should be small)
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- fi
-
- emake -j1 \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${D}"/usr/$(get_libdir)/libRmath.so \
- "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_HOME}/lib
- R_HOME=${R_HOME}
- EOF
- doenvd 99R || die "doenvd failed"
-
- dobashcompletion "${WORKDIR}"/R.bash_completion
-}
-
-pkg_config() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.8.1.ebuild b/dev-lang/R/R-2.8.1.ebuild
deleted file mode 100644
index 92bbbc789874..000000000000
--- a/dev-lang/R/R-2.8.1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.8.1.ebuild,v 1.12 2009/12/26 17:32:26 pva Exp $
-
-EAPI=2
-inherit eutils fortran flag-o-matic bash-completion versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="doc java jpeg lapack minimal nls png readline tk X cairo"
-
-# common depends
-CDEPEND="dev-lang/perl
- dev-libs/libpcre
- app-arch/bzip2
- virtual/blas
- app-text/ghostscript-gpl
- cairo? ( x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
- readline? ( sys-libs/readline )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base
- || ( dev-texlive/texlive-fontsrecommended
- app-text/ptex ) )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-R_HOME=/usr/$(get_libdir)/${PN}
-
-pkg_setup() {
- FORTRAN="gfortran ifc g77"
- fortran_pkg_setup
- export FFLAGS="${FFLAGS:--O2}"
- [[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
- export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_prepare() {
-
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
- || die "sed failed"
-
- # fix Rscript
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_HOME}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- --enable-R-profiling \
- --enable-memory-profiling \
- --enable-R-shlib \
- --enable-linux-lfs \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile(){
- emake || die "emake failed"
- RMATH_V=0.0.0
- emake -j1 -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake info pdf || die "emake docs failed"
- fi
-}
-
-src_test() {
- # we need to unset R_HOME otherwise some of the diff based
- # tests fail due to warnings in the output
- R_HOME="" emake -j1 check || die "Some of the tests failed"
-}
-
-src_install() {
- # -j1 because creates various dirs sequentially (hit should be small)
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- fi
-
- emake -j1 \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${D}"/usr/$(get_libdir)/libRmath.so \
- "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_HOME}/lib
- R_HOME=${R_HOME}
- EOF
- doenvd 99R || die "doenvd failed"
-
- dobashcompletion "${WORKDIR}"/R.bash_completion
-}
-
-pkg_config() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}