summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/javolution/ChangeLog8
-rw-r--r--dev-java/javolution/files/4.0.2-fix-java7.patch38
-rw-r--r--dev-java/javolution/javolution-4.0.2-r1.ebuild45
-rw-r--r--dev-java/javolution/javolution-4.0.2.ebuild4
4 files changed, 92 insertions, 3 deletions
diff --git a/dev-java/javolution/ChangeLog b/dev-java/javolution/ChangeLog
index 0fcf55bb1b3a..10b16d4e27ab 100644
--- a/dev-java/javolution/ChangeLog
+++ b/dev-java/javolution/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/javolution
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/ChangeLog,v 1.18 2014/09/07 08:57:30 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/ChangeLog,v 1.19 2014/09/07 09:19:13 ercpe Exp $
+
+*javolution-4.0.2-r1 (07 Sep 2014)
+
+ 07 Sep 2014; Johann Schmitz <ercpe@gentoo.org> +files/4.0.2-fix-java7.patch,
+ +javolution-4.0.2-r1.ebuild, javolution-4.0.2.ebuild:
+ EAPI bump, minor qa, added patch to fix bug #421863
*javolution-2.2.4-r2 (07 Sep 2014)
diff --git a/dev-java/javolution/files/4.0.2-fix-java7.patch b/dev-java/javolution/files/4.0.2-fix-java7.patch
new file mode 100644
index 000000000000..19d2275b8e0c
--- /dev/null
+++ b/dev-java/javolution/files/4.0.2-fix-java7.patch
@@ -0,0 +1,38 @@
+diff --git a/javolution-4.0/src/javolution/io/Struct.java b/javolution-4.0/src/javolution/io/Struct.java
+index 5198030..3def806 100644
+--- a/javolution-4.0/src/javolution/io/Struct.java
++++ b/javolution-4.0/src/javolution/io/Struct.java
+@@ -134,7 +134,7 @@ public class Struct {
+ /**
+ * Holds the outer struct if any.
+ */
+- private Struct _outer;
++ Struct _outer;
+
+ /**
+ * Holds the byte buffer backing the struct (top struct).
+@@ -145,7 +145,7 @@ public class Struct {
+ * Holds the offset of this struct relative to the outer struct or
+ * to the byte buffer if there is no outer.
+ */
+- private int _outerOffset;
++ int _outerOffset;
+
+ /**
+ * Holds the number of bits currently used (for size calculation).
+@@ -155,7 +155,7 @@ public class Struct {
+ /**
+ * Holds this struct alignment (largest alignment of its members).
+ */
+- private int _alignment = 1;
++ int _alignment = 1;
+
+ /**
+ * Holds the current bit index position (during construction).
+@@ -1607,4 +1607,4 @@ public class Struct {
+ }
+ }
+ }
+-}
+\ No newline at end of file
++}
diff --git a/dev-java/javolution/javolution-4.0.2-r1.ebuild b/dev-java/javolution/javolution-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..adad1def8bd1
--- /dev/null
+++ b/dev-java/javolution/javolution-4.0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/javolution-4.0.2-r1.ebuild,v 1.1 2014/09/07 09:19:13 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Solution for Real-Time and Embedded Systems"
+SRC_URI="http://javolution.org/${P}-src.zip"
+HOMEPAGE="http://javolution.org"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/javolution-${PV%.*}"
+
+EANT_BUILD_TARGET="clean _init_1.5 _compile jar"
+EANT_DOC_TARGET="doc"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PV}*.patch
+}
+
+src_test() {
+ java -jar "${PN}.jar" test || die "test failed"
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+
+ dodoc doc/coding_standard.txt
+ dohtml index.html
+
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc "${S}/src/${PN}"
+}
diff --git a/dev-java/javolution/javolution-4.0.2.ebuild b/dev-java/javolution/javolution-4.0.2.ebuild
index c76b86537a21..7a608be1febc 100644
--- a/dev-java/javolution/javolution-4.0.2.ebuild
+++ b/dev-java/javolution/javolution-4.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/javolution-4.0.2.ebuild,v 1.5 2008/03/30 22:05:30 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/javolution-4.0.2.ebuild,v 1.6 2014/09/07 09:19:13 ercpe Exp $
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2